Racerstar hall Sensor fail

Hey guys I’m in the final stage of completing my board I started planning this board about 6 months ago and I finally got my motors configured. I want to run in sensored mode so it has the smooth start without having to do a kick start. After watching several video about set up the board in the bldc tool from Jacobby and talking to @Deckoz I felt confident in my ability to know how to set it up. First motor config was fine hall sensor was picked right up and configured. When I shut down my board and plugged in my second motor the motor was detected but the hall sensor detection failed.

I’m using racerstar BRH motos from banggood.com. I have already put in a claim with banggood but I highly doubt I will get anything back from them. @Deckoz suggested I try to plug the motor with the failed hall sensor into the focbox that detected the first one. I will have to try that when I get home. I brought the motor in to work today so I could check the continuity on the leads to see if I can find the reason why.

1 Like

Yeah, definitely try that.

Also did you try different phase wire combinations? That could help as well

1 Like

I’m I feel like if it works on one but not the other it’s the focbox. And then Enertion will say user error fault pay us to fix it.

1 Like

I sent in my carvon motors to upgrade the adapters and when it came back the hall sensor detection failed on both motors.

After a lot of frustration, I talked to Jerry and sent them back to him to check. It’s back again and I haven’t tried again. But he said when he opened them up, the sensor wires were too close or touching the phase wires. I wonder if that’s your problem.

I’m not sure how I would open this motor it is basically like the old Olin board or the evolve motor.

Hit that search button. Likely to be motor not vesc. Could even be the hall sensor cable. Have a close look at the plug and check connections. Careful pulling that motor apart not to pinch your hand. Those magnets are powerful and when you remove the shaft they pull the rotor up.

Could you maybe post the link because I can’t find any for this motor

isnt racestar know for being a bit shitty?

It’s actually what evolve uses and ollin used the same motors as well

Ok so I have another idea.

Because @rich reminded me with this. I believe these cheaper motors(I ordered some of the bh5045) do not use 120 degree hall sensors, but side by side Hall’s. So the phase wires and sensors will only properly detect when plugged in a certain way. This may mean your plugging it in, and it is spinning the wrong direction.

To fix this due to hardware limitations you will need Ackmaniac ESC Tool 3.100. first because it’s a focbox and stock vesc tool has an issue initializing, which acks firmware fixes. But this also puts you on 3.xx firmware which has built in motor direction switching, unlike bldc tool.

Plug the motor in the same way as the motor that detected and dectect it on 3.xx, then change motor direction on the motor tab.

If this doesn’t solve it and both motors cannot detect sensors on that focbox I would consider a possible focbox fault… however if you are dead set on running bldc tool, then you can swap the hall sensor wires to be in the correct order with the phases to detect.

I think @Blasto or @JohnnyMeduse may have dealt with 120° vs side by side hall detection difference, if you choose to repin on 2.XX bldc tool


There are 6 possible phase wire combinations… I also had troubles with hall sensor detection but in my case 3 of 4 vescs had broken hall sensor ports :laughing:


Well I have a Mac and I’m not sure @Ackmaniac vesc tool would work on a mac

1 Like

Before you do this just try to change the phase wires and detect. If so and it spins backwards and you know it detects properly then do the firmware and void your warranty. Just making friendly suggestions. Just in case it is the focbox sensor port…

1 Like

Yeah I will try changing the phase wires. I have the motors mounted as rear wheel drive. I will try it on the focbox that picked up the hall sensor first then I will try different phase wire combinations. I tried to make sure that they were going in the same spots on both of boxes when I was configuring them last night.

1 Like

waaaaaaaaittttaminnnuuuuute…the 3.1 firmware can change motor direction in the tool so you don’t have to switch phase wires?!?

1 Like

Vedders vesc tool can do that as well. It’s a feature he implemented in the original firmware for all versions that start with a 3.

1 Like

When I ran my build on 5065 140k racerstars I had no issue running sensor detection (focbox, 3.100 firmware).

This is the order I (randomly) used when soldering the jst adapter:

I would try this and see if it works.

1 Like

So I tried every combination for the phase wires and none worked. I checked the motor on the other focbox and the hall sensor detection worked.

One thing I noticed is that the bemf and integrator limit where very different on the 2 motors I guess that would be because sensor worked on one and not the other. I believe those settings were very different on the same motor but different focboxes. When I do a motor detection it does give me values to put in for the sensor is that normal?

So I updated the firmware to ackmaniacs firmware. First after updating the firmware it locked up my MacBook Pro and I had to force quit the program. Then started to configure the motors and the motor detection on both hall sensors are now failing how can this happen the one was detected by bldc tool and will not detect on ackmaniacs.