Radio Interference Causing Full Throttle Acceleration?

So yesterday I was taking my board to the shops in the village for the first rather than testing down a bridal way and I think I got some sort of radio interference causing my board to go full throttle.

I had to bale and got a black eye and fucked up shoulder for my troubles.

I use a GT2b with a Mad Munkey enclosure. I have the receiver antena outside of the board enclosure, stuck to the board.

I put the board in the passenger seat of my car, turned it and my remote on and drove it around a residential area today to see how it would behave and I was getting random periods of full throttle.

Has anyone experience anything like this or know how I could fix it?


That really blows man. Let’s start with a bit more info then.

1 - Did you set the failsafe for the radio and receiver? In most cases we don’t use brake as the failsafe. We just use neutral. That way you don’t get thrown off if you loose signal. Find the manual here:

2- Did you calibrate the remote in vesc/bldc tool if that’s what you are using?

Post screenshots of the app settings in the vesc/bldc too if you can.

This will be a good start. Before that make sure all of the wires are plugged in fully. You can try to wiggle them while the board is on to see if they are too loose.


1 Like
  1. Yes, I have set the failsafe of the radio and receiver.

  2. I did calibrate my FOCBOX’s/remote with the bldc tool latest software.

I don’t think it is a loose cable but I will take the enclosures off and check all the connections tomorrow + take screenshots of my app settings.

The issue never happened before, only when I started riding in residential areas, which is why I think it is related to radio interference.

Bench test your board and turn off your remote, see if the board accelerates or not. If it does not, the issue is not due to signal interference. If it is, it’s due to interference and a bad failsafe.

See what happens when your board is on at half throttle and you slowly wrap aluminum foil around the remote. What does the board do?

DO NOT USE FAIL SAFE ON RECEIVER. This cause full acceleration. Please disable it Use fail safe on VESC Setting as neutral, not brake.

fail safe on gt2b is made for glow engine cutout. So in electric motors it is best not to use. I’m not sure why but it always full accelerate in some esc including vesc

1 Like

Yep, relying on gt2b failsafe can be dangerous. I explained why in this thread and the work around.

Original posters problem could also be troubleshooted with an arduino too.

1 Like

Strange the gt2b has been very solid. There is some really good advice below my first post. Try those out then post the screen shots when you can. I’m also curious to know what happens when you turn off the remote while everything is on. If it accelerates then, the failsafe is set wrong and you are having signal issues as others have said too.

Good luck