Raptor 2.1 unrideable

After waiting 8moths+ for my board to arrive i have had nothing but trouble with it , first thing out of the box the remote was broken , ,fair enough these things happen ,contact enertion and they say they will send a replacement straight away,so im pissed off when a week later it still hasn’t even been dispatched yet (after waiting 8 months maybe they could have tried a bit harder)3 weeks later i get it , then the togle that the battery charger pluggs into breaks off ,another 2 weeks for that part to arrive complete with another part that i new nothing about ,i replaced the toggle and the board still wouldn’t charge,turns out the other part that came with the toggle had to be installed becuse of a fault with the original part ,but not a word from enertion about it .so I finally get to ride it but there is a bad vibration in the rear wheels and they are so hard its like riding with concrete wheels . I persevere with the board only to barely touch the brake at near full speed for the board to stop dead and i end up going down for a nasty crash and off to the hospital . So then the remote doesn’t work at all and after many many emails to and from enertion ( when they do reply) i think i have the problem sorted and take it for a few runs and it seemed ok so i was giving it a go flat out up a reasonable hill and half way up it just lost all power and stopped and i keep going resulting in another bad crash and another trip to hospital, and on top of that i have a $2000+skateboard that i have absolutely no confidence in riding cant sell it with any sort of clear conscience and after requesting a refund was told apart from the 20% restock fee they charge a refund was going to take months and months miinimum. What do i do


Cut the losses and buy a Metroboard?

1 Like

Join a moral support group with @seanhacker


That sucks man but it’s not an unfamiliar story…

Maybe try salvaging what you can outta the board for a diy build? (Battery, deck, vesc)

Sell the hubs to someone that wants to deal with it. Replace with a simple belt drive?


Im surprised they haven’t been sued into oblivion. It’s like if your new car’s brake pedal fell off, you crash and almost die, and they send u a replacement car with the same pedal. Dare I spam now? I do


Sorry to hear you’ve been having such bad luck with your board Scott!

A few questions:

  1. Does the board turn on and operate as normal without riding it?

  2. Does the Unity have the most recent firmware?

  3. Are you calibrating the remote before turning the board on every time?

Let me/us know, thanks! :slight_smile:

When he described the board coming to a stop by just barely touching the brakes, that immediately made me think of it being him not calibrating correctly. Same thing when he went uphill. If he somehow pushed the remote past what you calibrated as ‘full throttle’, it’ll cut all over until you return back to a calibrated range. I’ve had both of these things happen to me too, but it’s all about calibrating correctly every time.

Calibrating luckily won’t be necessary with the Focbox Pilot, which I strongly expect Enertion to include in the R2.1 package instead of the Nano-X.

1 Like

Why is this still a thing? I don’t understand why a $2000 board has a remote that’s out preformed and less reliable than almost every other remote readily available. How is that not a priority to fix sooner?

The pilot project sounds great. And im looking forward to what enertion has to offer. But this really should have been addressed sooner.

No doubt the Pilot remote will be standard with Enertion boards once it’s available.

I wonder how many died so far :thinking: not like they make it back to the forum


Yes it has the latest firmware and yes I calibrate the remote, the thing is I sent a video to enertion showing the board glitch whilst hooked up to my laptop 2 weeks ago and as of now not a word from them

1 Like

And to be perfectly honest why the hell should you have to calibrate a remotevevery time u us it


Hey man. I see you have just a small issue with the hardware of your remote but this seems to be just that. The other issues I read are 100% user error, learn how to calibrate your remote everytime you ride it, charge it 100% at least 2 times a week.

I know enertion is getting a bad rep lately but rants seem to be very emotional and exaggerated.

I had my board for more than a year and it was able to perform pretty realiably, no major catastrophic problems with it

1 Like

Thanks for your advice champ , but the remote was fully charged and calibrated beforehand, so maybe before you start deciding what is and isn’t rider error you check that your not just bumping your gums and just because you have a board that hasn’t had any issues does that mean that every board is free of faults

1 Like

Just one more thing there champ , would you be so kind as to tell me how you can tell that anyone is exaggerating, because I’m pretty sure that my elbow that needed to be stitched up and the knee that now needs a reconstruction are a reasonable indication of a decent crash , and before you bestow me with anymore of your skateboarding knowledge I have been riding and building skateboards since I was 8 years old and seeing as I just turned fifty a few weeks ago I do have a limited amount of knowledge on the subject


Everyone’s conveniently ignoring the fact that he’s said 100X he has calibrated the remote before every ride…

Edit: I’de be pissed too. Just sayin



Seems reasonably upset.

By blaming the person who was injured and than claiming the board must be fine because his is.

There’s plenty of faulty raptor 2.1 reports. So dont act like he’s just making stuff up because hearing the story.


you know what they say if it looks like a duck:

To me, it sounds like a user issue and I’m not going to go out and accuse enertion of shipping a dangerous product if there is no actual proof. I’ll eat my own words if he can provide evidence that its not user fault

Guess that make you an asshole than.

Maybe open your eyes? I know of a few people with Unridebule raptors. The last one that tried to post about it got banned…



First off, I’m sorry if I sounded smarty and pretentious, not my intention to upset people at all.

What you are describing feels like a remote that is loosing connectivity with the receiver defaulting in a reset in calibration during riding, if this happens any throttle input acceleration or brake will feel like full brake or full acceleration even at really small throttle movements, this usually happens when your remote has low battery but not completely dead or when there connection between receiver and remote is lost.

You should always throttle up and down fully with the remote on and the board off, then turn on the board on. If you ever turn the remote off during a ride session, throttle up and down again fully before hopping into the board back again. If you have done this in all your rides, then forget about this comment.

You should always wear protection while riding and it should even be mandatory on new boards, just an advice from a fellow member that had pretty nasty accidents when I was younger.

If I were you I’d log into unity UI and look at ppm settings with the remote, see if it does strange things when you move the throttle forward and backwards, try to keep moving the throttle for 5 minutes and see if it resets, if so ask enertion a new nano x + receiver as your is no longer reliable.

But this is all I can give you as friendly advice, I see nothing else wrong with the board that could cause the issues you have experienced