Raptor won't charge

Hi need help fellas my raptor doesn’t charge . When I put on charge the ℅readout on the display doesn’t increase nor does the charger light go red to show that it’s charging.

The board works fine just doesn’t charge… The day before when I turned on the board the LCD display on the space cell was display volts not % battery life ?? Anyone come across this issue ? Thanks in advance.

Have you emailed Enertion support? They’re pretty quick at responding since hiring dedicated support staff. If there’s a fault with the hardware they’ll have a new battery shipped out to you 100%. Raptor VIP Club baby :slight_smile:

@onloop and @carl.1

1 Like

Yes I have contacted support , billy at enertion sent me a link to a post on here , but it’s all just random topics.

I was just hoping it might be a simple fix , like something needs re soldering or something’s come loose.

I’ll test the charger tonight with a multimeter, to rule it out the equation. I just wandered if anyone else has experienced the same issue and how they addressed it…

I thought I had this issue on the very first day my SpaceCell arrived but just noticed the plug wasn’t pushed in all the way… (the plug going into the battery itself).

If I were you I’d take a video of what’s happening, post it here and also send it to them for illustration purposes. Personally I’d be a little uncomfortable messing about with my battery internals as I have no clue what I’m doing. If there was a genuine hardware problem which I could demonstrate on video, and I was inside my sweet Raptor VIP club 12 month warranty, I’d expect that no questions asked exchange to happen fairly swiftly. Which I’m sure it will if things are truly as you describe. Test the charger and take it from there dude…

problems been solved.

tested the ac adaptor with a multimeter , result was no power reading .

so i checked the fuse and it was blown.

Realised what i did wrong .:confused: dooohh !!!

The adaptors kettle cable comes shipped with an 2 pin EU style plug end.

i purchased a plug in adaptor off the shelf at morrisons .

I should have looked more carefully at the packaging , by mistake I purchased a 1 amp rated fused shaving plug adaptor …lol

I ended up butchering the kettle cable plug off and retro fitting a standard uk plug and appropriate fuse.

Mind you i’m still a bit puzzled as to why the boards lcd displayed voltage on display… instead of % battery life…??

but for the moment its working fine and charging as I type , hope this post helps someone … from making the same mistake i did. A simple mistake but problems solved.

1 Like

thanks for being humble and updating us :wink: