Remote input not registered by vesc after failure and subsequent DRV replacement

Looking for input and ideas as to what might be causing this issue.

I burned a DRV after overheating a Jacob’s hubs motor. I replaced the DRV and now there are no faults registering but I’m unable to control the VESC with the remote.

When viewing the remote input under the ppm tab it just stays at 50%. I’m also unable to control it via the CAN bus where it says no response from hardware.

Any ideas?

I’ve noted that the motor detection works and I’m able to control the motor via the arrow keys, I just can’t control it via the remote or the master VESC.

I’ve also verified the remote/receiver is working since when I plug it into the other vesc it works just fine.

Thanks guys


Have u seen this before my good sir?

Have you ensured that the remote is binded correctly? It’s probably worth trying to rebind it if you haven’t tried

Hi Luke,

Thanks for your response. I have tried rebinding the remote. This is a dual VESC set up. The remote works just fine on the 1st vesc, but when I plug the receiver into the 2nd vesc it does nothing. I know it’s not settings related as I’ve copied the settings on the 1st VESC to the 2nd.

Pretty confident it’s hardware or firmware related.

I’m hoping one of the VESC gurus, maybe @chaka can point me in the right direction in terms of board components to test or replace.

Can you check if you have a 5v on the ppm pin ? Or if the tvs diode (d5) is still alive ?

Ah, are your ppm settings exactly the same on both vescs? I believe that on the master vesc (controller ID assigned is usually 0) you’re supposed to have “send status over can” unticked And for the slave vesc, it is usually ticked. I may be going down the wrong path, but I just want to help how I can :stuck_out_tongue:

I do have 5V on the PPM pin and D5 checked out ok as well, any other ideas?

That’s correct Luke, send status over can was checked for the slave and not for the master when I was trying to drive the VESC via CAN. I also tried to drive the VESC via PPM control and ensured the PPM was selected under the application tab as well.

Where you able to run a motor detection after you replace the drv

Yes, I was. Motor detection completed successfully.

Are you sensor or sesorless, and can you check if the motor is set properly?

I had a similar issue with my VESC, running in hybrid mode, one of the wires on the sensor cable was disconnected.

Smh, I didn’t reboot the VESC after changing from no app to ppm on the App.configuration tab.

Thank you both for your help.