Remote not working but keyboard does

Ever since I got some water on my vesc my remote hasn’t been working however when I plug it in to the vesc tool there are no faults and I can use the keyboard to control the motor but the remote doesn’t work. I already went to the ppm settings and everything is fine. I had an extra receiver lying around so I tried that one as it came from a different mini remote I don’t have anymore but that still doesn’t work. Is it possible the ppm port on the vesc is the problem?

can anyone help me please

Looks around where the ppm port and see if you can identify any shorts or signs of water damage?

i did it doesnt look like any shorts and no burn marks

Its possible but its more likely the RX is just messed up from water damage.

1 Like

Borrow another remote and receiver from someone and test to see if thats the case.


ok i will try that and post back soon

1 Like

So I tried a different remote and still nothing. I realized that when I turn in the vesc the blue and green light stay on all the time. Isn’t the green light supposed to only go on when you add throttle. Here’s a picimage

when i use the keyboard the green light just gets a little lighter

now periodically the keyboard works but then it will stop working and the motor will stutter

now when i unplugged the receiver from the vesc the keyboard works. is the ppm port possibly the problem

I have no clue. 8d talk to @JohnnyMeduse, see what he says.

@JohnnyMeduse can you please try to help me out here if i have to replace me vesc or something. Thanks

Do you have a Multimeter ?? Could you check if R20 is 10Kohms

1 Like

sure will check now

nevermind found it.

its 9.87k. Is that good or bad?

that good… humm can you post your setting?

1 Like

Also the green light doesn’t blink 3 times when it starts up. image

What software are you using?