Remote pairing issue

When I tried pairing the remote to the master vesc, the light signals that it has connected, but the motor won’t turn. I had this same issue back when I was pairing my remote for a single motor, and I somehow fixed it(forgot how exactly maybe by adjusting motor settings?). I was wondering if yall could help me?

Here are the links to the videos for my vesc config and setup:

Did you “write” your configs before disconnecting?

I saved it each time

So in your master input video you didn’t set the parameters for the trigger.

When yoyou get here, you need to full throttle. Don’t worry it won’t turn the motors. So, full throttle then pull back to full brake. Then hit apply Screenshot_2019-01-02-20-20-25

i had the same thing!!! check the hall sensor, or whatever its called connecting remote to the vesc, and flip it. red should be to the left. i think… did that make sense

1 Like

lol PPM cable.

1 Like


Um, my ppm cable has the red line in the middle?

1 Like

you my dude are a life saviour

1 Like

thanks so much for helping me out!

1 Like

Glad I could help. Stay safe

i haven’t made a board since the summer and im tired…

sorry, one last question. I thought that after one motor runs with the controller that after connecting both vesc via canbus, both motors should work with the remote?

because right now, only one motor is turning when I flip the remote after connecting both vesc via canbus?

I’m not too familiar with canbus. @Andy87 @mmaner @Sender

1 Like

do you reccommend using split ppm?

Did you set the second vesc as slave? You need to configurate the second vesc too.

Yes, I set the second vesc as slave

You also made motor detection on the slave and still only one is responding when moving the trigger?