Setting up my ESK8 VESC - FOCBOX

I finally have most or all of my parts to begin my build. Is anyone free to walk me through setting up the correct BLDC settings for my components. I can set up a teleconference tonight and we can review the settings together. Let me know if anyone has some free timelater this evening.


If you post here more info about how many motors,motor type, info about battery lipo or li ion (xSyP) someone surely will help you easily. You should also decide if you want to run in foc mode or bldc. I don’t remember sincerly if in bldc tool there is the ? Symbol next to every conf but for sure in vesc tool there is one and it’s very usefull to well understand everything. Btw welcome to this awesome hobby.

you can make this a lot easier by listing the specs of your battery and motors theres a lot of threads on motor detection too its pretty easy if you read a little bit, better to learn how it works than to let someone make it for you, you will need it in the future for sure

1 Like

Basically the new vesc tool does this for you with the “wizard setup”

Ok - i have tried to do it myself and cannot even get the focbox to connect to the PC. Not connected. I tried hitting the refresh and connect buttons on the application… Any other advice ?

Tried checking for new port

What power source do you have for the vesc? Usually when the vesc doesn’t connect it’s either the usb cable or the drivers on your computer

FOCBOX can be fussy with which USB cable you use. Try another few.

Make sure that the usb cable it’s inside the port of the focbox because some microusb are larger than the hole and it’s not a good contact for data transfer…

Use a stronger, thicker micro-usb cable. The one that came with my focbox didn’t work either, i used one of my own.

You have to use a usb data cable and not just a charging cable ie the one that comes with a nanox if you have a ps4 the remote charging usb will work with it.

It was the usb cord. I originally used the mini usb from the nano x remote. It did not work, tried another that I had and whella!! I used the following video to set up my Foc box.

Yep figured it was the usb I had that same thing happen