Setup two vanda vesc's

I am trying to setup my two vanda vesc’s HW 4.12 for my first build. Using the newest vesc tool (version 1.08) I flashed the newest firmware 3.54 on both of the vesc’s. Since I want to setup a dual hub motor in BLDC mode I had to go to “Wizards -> Setup Other Motors”. I set the Amp limit to 15 A / -7.5 A. The motor was recognized and also spinning. I applied the changes and did the same for the other motor. So far so good.

I have both motors connected over CANH/CANL and when I go to “Setup Input” the following message pops up:


I don’t understand this, both are at Firmware 3.52…

As a workaround: I noticed that I don’t get this message when I disconnect the receiver (Firefly receiver) shortly from the board. This way the setup continues:


I calibrated the firefly remote and pressed Finish.

The problem now is that I can only spin one motor. When I swich master/slave the other motor spins only. By the way the receiver is connected over PPM.

Next I used the vesc tool v0.95 and flashed firmware 3.40 on both vesc’s. After the motor/input setup I was able to spin both motors but in the opposite direction. After switching two phase wires on one of the motors I was only able to spin one of them. Strange.

Does anyone have an idea what I can do to make the motors work? Any help is appreciated.

Maybe this helps

I saw that video. There is a more recent version of the vesc tool (1.08) but it’s similar and not describing my problem.

You need to do motor detection again after swapping phase wires. Instead of phase wire swapping you could only apply invert motor direction in the vesc settings. This wouldn’t need a new motor detection.

1 Like

Thanks a lot, I forgot that. When I use Firmware 3.40 it works now. But it still doesn’t work with 3.54. Is that normal?

I have no experience with the new FW, can’t tell you.


I have the same setup but I have not experienced this with my vanda’s but I also set each vesc separate set one as slave and connected by self made canbus. Maybe this week I can reconnect and see if I can simulate the same problem you are having. Why is the amp limited so low

1 Like

it was just a first quick test. I am using a 10s4p battery pack over a HCX-D223V1 bestech bms. I thought 15 A per motor should be ok to not let it run too hot. What are your Amp settings?

30 and -10 but I’m not home till Monday though to double check. I’m also running a 10s4p. 4 separate BMS

1 Like

Do you have the newest firmware 3.54 running?

1 Like

Yes it was the first thing I did

1 Like