[SOLVED] Getting FULL Brakes when trigger is released

I just replaced one and repaired one Enertion 6355 motor on a Raptor. Bench test was fine using a Winning remote, wheels turned and SLOWED to a stop when I released the “trigger” and halt to a stop when I pulled it back…the next step was replacing the reciever and remote to the Nano-X. It paired fast and easy, BUT now when I let go of the trigger it brakes immediately. ALSO the second the board is turned on the brakes are on. What did I miss in BLDC?

have you changed the PWM settings?

1 Like

You need to calibrate your remote

I’m not sure if I’m doing something wrong. the remote binds with the receiver and I can control the motors. Within BLDC tools I DISABLED the Control Mode and clicked write, rebooted and read…it shows the disabled, but the remote would still work.

Seems to me and others this is configuration issue within the esc or the vesc.

what does that mean? I have a faulty vesc?

No. Like others said you need to configure your vesc pwm setting. You might need to recalibrate your remote.

I did everything Jacob’s video showed and I still have the same issue. I did the same thing for my other board and it works…can this be a Nano-X problem?

Also, BLDC doesn’t display the pulse rate so there’s nothing to adjust

It should, make sure you check the box that says show pulse (or something like that). @Ackmaniac’s software actually has a wizard for setting it up.

Yeah, I clicked the DISPLAY box. but nothing shows up. I clicked the disable button, wrote to vesc, rebooted then reconnected, but the remote still works. I’ll pair the vesc back to a winning remote and see it it changes anything. I have a feeling the Nano-x is my problem right now

plugged into wrong vesc?

this evening’s finding…I clicked on [START DETECTION] and only one motor (the one connected to the VESC my usb cable is connected into). EDIT found out this is normal as each vesc needed to be programmed individually.

@boards I’m connected the VESC that seems most obvious. They are glued into the case by Enertion (Raptor) and the other VESC’s usb port is not accessible without cutting the glue

@boards well well well. it looks like I was connected to the wrong VESC afterall…which begs the question of why the hell whould Enertion make the correct VESC to connect to so hard to get to?!?

I now was able to see the pulsewidth move up and down, BUT after entering the min and max, rebooting the VESC and re-enabling to “Current no reverse with brake” the remote no longer responds. **EDITgot it working FINALLY, but still not sure what order and how. I unchecked the [Send status over CAN] on both VESCs rebooted and rechecked each one and suddenly it worked.

totally trial and error.


rode two miles on it this morning. running perfectly and didn’t street my face. Nano-X’s beginner mode made the Raptor easy to ride for slow test, but the brakes seems really hard compared to when it’s in normal mode.

So what I probably did wrong was a combination of these things on a dual setup:

  • Did not do BLDC setting on the “other” VESC assuming that if Enertion hot glued the vesc close to the point where you can’t plug in a usb cable it much not been necessary. I literally cut all the rubber from a usb cable so I can plug it in. Having to program each vesc individually was new to me. I thought that was what the send status over can was for?

  • Reenter the remote controller IDs on each VESC to 0 and 1

  • Mirror all settings on both VESC

  • un-select and re-select “Send status over CAN”

  • lots of cursing at myself

Side Note:I really like the even torque on dual 6355s compared to my single 6374 first build, I can’t imagine the Raptor 2 being better, like how is that even possible?