[SOLVED] VESC motor not being detected or turning red blinking light

After receiving my VESC I plugged it into my battery, connected my motor (enertion 6374) to the VESC, connected my receiver (from the enertion remote) to the VESC and turned on my battery. Lights on the VESC were turned on and I binded my remote to the receiver successfully. To test to see if the motor would spin I pushed forward on the remote however nothing happened. At this point in time I thought it was a problem with the remote so I connected the VESC to my computer to see if the VESC would work with the BLDC tool. My VESC came with the latest firmware 2.18. I was able to successfully connect to the vesc, read and write limit values to the VESC however when I tried to detect the motor the message “Detection failed is displayed”. There is a pink flashing light on the VESC which im guessing is used to show errors. In the Terminal section of the BLDC tool no faults are displayed when faults are typed in. Is there anything I can do to fix or will I have to get a new VESC? Thanks for any help

I’m not sure what you mean by the terminal section, but VESC error codes appear in the realtime data tab. Does the motor spin up at all when you run detection? If so, I would turn on realtime data, then run detection, and quickly switch over to the realtime data and see if any error comes up.

Check the wires from the motor to the vesc are secure.

The bldc terminal I was talking about. The motor does not spin or move at all.

type “faults”

When I enter that into the terminal the message “No faults registered since startup” is given

take pictures of your setup

I am running 2x6s 10,000Mah batteries in series, using a circuit breaker as an ON/OFF switch, connected to the VESC.

That looks like it could easily short the motor phase wires.

Good point, I will add some heatshrink around the connections. Could this have potentially caused any issues?

Shorting of the phase wires can blow the drv chip.

Is there anyway to tell if the chip is blown? From the exterior there seems to be no damage.

the bldc tool should tell so.

Does this say anything ?

As @Lizardking0069 said, those phase wires are very close to shorting, make sure you insulate more. You can check for faults if you turn on active sampling under “real time data”.

Did you make sure you set your PPM settings and changed the control made to duty cycle/current/pid?

Nothing shows for the fault code

make sure you check “active sampling”

There is now a fault code saying OVER_VOLTAGE

I am not sure what the PPM settings are and I dont know where to change the controls to duty cycle/current/pid

What’s your max input voltage? you shouldn’t change it from the default 57v