[SOLVED]VESC Motor output power issues

Hi, I am very new to making e-boards, but have worked in making RC planes and quad copters. The issue that I ran across when trying to make my e-board is that my VESC seems to not be outputting nearly enough current to the motors.

sorry for the potato quality vids…

When having the board upside down and no load on the wheels the VESC is able to get the wheel spinning. When doing this the current draw is around 1-2 amps. When the board is upside down like this and the wheel is spinning at full throttle, I am able to grab the wheel and stop it with my bare hand. Video of what I mean: https://drive.google.com/file/d/0B8E6-v_xdAngN1A1OGpQVlJ1Nk0/view?usp=sharing

When the board is right side up, but only under the load of the weight of the board, it is not able to to move itself. https://drive.google.com/file/d/0B8E6-v_xdAngOXVFeVRLV0E1WDQ/view?usp=sharing

If you do however give the board a push, it is able to move a little bit, but not sustain the movement. https://drive.google.com/file/d/0B8E6-v_xdAngdF9FMEFZWTZQOVU/view?usp=sharing

In all of the videos the throttle remained at full.

In the BLDC tool, the motor detection fails.

A little about my setup:

  • Turnigy aerodrive 63-64 245kv
  • Enertion VESC ver. 4.12
  • HK GT2E transmitter and receiver combo
  • BLDC firmware ver. 2.18
  • 2 Turnigy 5000mAh lipo’s in series

Some screenshots of my BLDC setup:

Thanks for any help!

Can you post a picture of your Advanced section? Also, where did you get your VESC from?

did you do a motor detection and apply the values?

Also, if you’re not running multiple VESCs, unchecked “multiple escs over can” and “send status over can”. These settings should never both be checked on the same VESC.

Here is the Advance section:

I ordered the Basic VESC from enertion boards about 2 weeks ago

Thanks for the speedy replies

You need to Read Settings before, all 0’s doesnt look right

I ran the motor detection, but it failed. I then ran it again looking at the real time data with active sampling on and got no error codes… So I do not know what exactly is going on with that. I am not running a dual motor set up, so I think that I need to have both “multiple ESC’s over CAN” and “Send status over CAN” unchecked… Correct?

Thanks for the help!

Ok, so the advance screenshot in my previous post had the VESC not connected, here is the correct one with the read values… sorry for the confusion

Hmm, that looks fine. But if motor detection failed then you will have problems.

I read somewhere that the motor detection should be done with a lab power supply and not just the batteries. When I tried it, I was just using the batteries, do you know if that is what is causing it to fail or what.

The lab power supply is for the first power on, to prevent as much component damage as possible in the case of a short or other problem.

batteries is fine if you know the batteries are good. Yes have both options unchecked. You need to be able to do motor detection, so don’t use the board until that gets sorted out. Does the motor spin at all during detection?

Ok, so I have both unchecked now. I’ll make a video of the motor detection really quick because its kinda hard to explain…

Ok, here is the video, https://drive.google.com/file/d/0B8E6-v_xdAngMldPOVZxVEUxaDA/view?usp=sharing

It says “detection failed” in the output box for it… forgot to show that in the video

did you “read configuration” before trying a motor detection.

lol nope, I’ll try that right now

Still failed, “bad detection, results failed” is what the words highlighted in red said down at the lower right

You could try flash the latest firmware.

what’s the voltage you’re running?

This post was flagged by the community and is temporarily hidden.