Space cell is dead or dying.. please advise

Hi there.I have the space cell which I believe is the Gen 3, with the green lit LCD and the push button on switch. there are two different indicators on the lcd, one is an image of a battery, and the other is the charge percentage.

When I got the battery from a friend, the battery indicator showed 3 or 4 bars out of the total on a full charge, the charger worked great, and the bars over the weeks have dwindled down to nothing. The charge indicator still shows 100% after a charge and lasts a long time. But now the battery just shuts off mid ride, and won’t stay on for more than 5 minutes. full charge, no bars.

I only charged it maybe 15-20 times since I’ve had it. It worked great until now.

What is wrong? have I reached the end of the battery life? is there a part inside that is failing?

Please excuse my ignorance, I am pretty new here, and DID try a search for the same thing but couldnt find anything relevant.

Thanks in advance for any help.


I think the best will be to open that space cell and check each cell with multimeter, that way you will know for sure if something wrong with cells! If they all fine than check all connections/ nickel strips/ wires. If all fine than maybe BMS is faulty.

So open it and check, good luck, hope there is nothing serious.:wink:

1 Like

well… good news. The problem is the button switch not staying depressed. the battery works fine. the indicators were just showing faded. soooo… I need a new button? lol.