Space Cell Pro 4 Issue | Showing only 100% | Fixed

So I finally got the Pro 4 and it looked and worked good out of the box, but after I put it on my board (BTW, my board has a large concavity) it now just shows a constant 100% on the display.

I don’t even know where to look at for the issue.

Also, it still works. Plugs into the VESC fine and runs the motor.

@lilracerboi

The button on the back of the screen has likely been held down, it happened to me. If you turn it on and it reads anything other than L10 this has happened. So peel back a bit of the foam and move the first lot of chips out of your way (not too far though) and locate the button. Hold this button down whilst turning on your space cell and it will flash on L3 press the button multiple times until it reads L10 and turn it off. When you turn it back on it will display L10.

Alright, that worked. Thanks a lot man!

I tried pressing the button earlier, but I didn’t know about holding it.

1 Like

How bad is it if the plug on the space cell activates the button on the bms? I guess the easiest solution will be to switch on the space cell before I unplug the space cell so it just changes between volts and percentage instead of L3/L10?