STRUGGLE Day - Escape and GT2B problems

Noob thread. I’ve spent my whole day trying to update one of my build. It was long and boring I had a tons of minor problems. Anyway it’s been literally 2 hours that I am struggling to calibrate a remote on the VESC Tool. So far I have tried : 3 x GT2B 2 x nano X 1 x winning

All the remote binds, I have the solid lights etc etc… But never a single pulswidth on the VESC tool. It’s so infuriating. I tried all the combinaisons I could imagine. Nothing works.

1 Like

You sure you plugged in to the right channel on the receiver and the pins on the escape in the right order?

You have this if you have the receiver plugged in the wrong way round. Turn the plug 180 degrees

1531412338197 1531412388229

I have done this 50 time already unfortunately

Stupid question, but you set your escape to ppm mode?

Throttle is on channel 2 and not 1


Like @Silverline said. Rc remotes channel one is for steering and 2 for throttle. Esk8 specific remotes like nano-x use channel 1 for throttle. It’s an easy mistake. Hope it all goes well for you.

It’s an impression on the picture but the cable was plugged into ch 2 Anyway the issue was solved but don’t know how, it just suddenly worked when I tried the same procedure on the other Escape, I have tried again on the other one and it’s not working so I guess the ppm port of my second escape has a cold joint or something!


Have you adjusted your min and max on the vesc tool and turned on the readers