Starting Tips | Ask Questions | Introductions | Categories

Torqueboards 12s setup, wont drive, just binds up

Hello All!

I believe I may have seen something like this before, reaching out to the community on ideas of what could be up.

So the first time something like this happened everything got fried. This time around I have managed to not fry everything. Basicly what happens is I turn the board on and pull the gt2b trigger, motor just cogs. With the board on its back the wheel just goes forward a bit then lurches back, then forward, etc etc.

When I go to turn off using the cutoff switch it still keeps twitching so i have to unplug the battery. Took everything apart, plugged the battery in and noticed a spark. With a cutoff switch there shouldnt be a spark so this arose some worries. The motor off of its belt and trigger pulled, she stutters but spins up.

Not sure what just happened but putting everything back together now. Going to space things out some more in hopes that the cutoff switch just got hot from a heavy ride. Last time this happened to me it was a heavy ride that I had just got done with when this happened. May not be a problem with the ESC but the cutoff switch itself… hhhmmmmmmmm

I doubt it has anything to do with the antispark switch, do you have another ESC to test with?

I have 3 VESCs that i had gotten from you onloop. Thinking it might be time to give up on torqueboards as a backup board that can take the beating. Will have to wait a few more days for the bullet connectors to come in from hobby king so i can get that straightened up. Hopefully can get one of these kama controllers working. But now i need an anti spark switch that i can trust.

With everything taken apart i plugged the battery in and everything powered right up. This cutoff switch isnt doing anything basicly. This is laaammmmeeeeee.

EDIT: with everything put back together, while the cutoff switch isnt doing anything I did manage to get the motor to spin proper. No idea how I did it, but I just got off a test run and it seems to be working fine? Gonna have to get an antispark switch as some backup. Odd times!!!

Is the cutoff switch one of Touqueboard’s too?

Yeppers. 12s esc and 14s cutoff switch both from torqueboards.

It sounds like this isn’t your main problem but I had the same issue with my Tourqeboards power switch where it didn’t actually break the circuit when switched off. I sent it back about two months ago and am still awaiting a replacement.

I bought one of those switches too and straight out of the packaging it never worked. It’s in my pile of disenchantment. Doubt I’ll ever send it back.

Shit so i am not the only one whos had problems. Good to know. Anybody have other suggestions on what to use? Didnt vedder create one of those as well?

I decided to just roll with XT90 antispark plugs and a loop key. Simple, bomb proof and inexpensive.

Lever had problems with that switch too!

Damn I was hoping I was the only one. I loved the way it looked when it was all lit up blue. Enertion seems to sell a similar one too (hopefully works better) but it’s out of stock. @onloop do you expect to get those back in stock sometime?

@torqueboards should check out this thread.

…SPACE CELL :slight_smile:

I permanently boycotted the factory that makes them…

1 Like

@Sharkface - PM me and we can get that worked out.

@Siggs3000 - I’ll PM you and send a replacement.

Yeah, unfortunately the factory that makes them uses crap mosfets and I even offered to pay more to use better mosfets but to no avail.

I’ll be testing out Ben’s as it’s a more proper on/off switch for those who still use Lipo.

Yyeaahhhh… ill be talking to you about that one soon…

And in regards to bad FETs @torqueboards… maybe you should find a more reliable company/manufacturer… unless im the only one readin your last post as “i knowingly sold under par parts”

You could also get the manufacturer to do better crimping on the servo connectors that @evoheyax and I had problems with.

I don’t want to be all “I told you so” but this thread is full of the exact reasons that I will only use a physical breaker switch on my boards.

I dunno. safety and stuff.

1 Like

I got my HV electronic switch from Torque Boards yesterday. Tested it right off and it works perfectly.
Not even a trace of spark when connecting 12s battery.
There is a slight delay when turning it on and when turning it off, it takes about a second for the circuit to drain out.( I can live with that.)
I tried using a mechanical breaker switch before and it wore out quickly. When I took it apart I found that the contact points where fried. 12s produces a heavy spark and a mechanical switch doesn’t eliminate spark it just relocates it to the points in the switch.

If you had used an xt90 anti spark plug with your breaker it wouldn’t have worn out.