Trouble with flipsky reciever, 6.6 dual etc

So, my remote stopped controlling vesc. So, I check, and no led on receiver. MAJOR trouble finding new receiver, and still not sure I have the right one.

Should all compatible receivers go live and jumpy? And pair or not depending on correct remote?

All receivers I plug in, remain flatline. I have used both sides to plug receiver, plugged usb into both sides. chose both can and local. Nothing seems to get a live receiver.

Can the ppm channel be burnt out on both sides somehow?

Do I need to order the remote WITH matching receiver? Is there something wrong with vesc? I have reran all motor setups, and it works fine.

Tried pairing, and nothing happens, but I guess that is to be expected, till input wizard gets a jumpy live signal. HELPPPPPPPPPPPPPPPPPP.

I dont know how to proceed. My board worked fine for a year.

Flipsky 6.6 dual, vx2 remote. I have tried both new receiver, and older ones.

Shouldn’t you be using the uart plug in?

Yes, I see that it is a uart plug. And so, I routed output to uart. I also tried ppm. I tried every combo known possible. Is it possible that the uart circuit blew? I wouldnt think so, as it is only communications. And, it still lights the blue led in receivers.

I gave up, and ordered another vx2pro, with receiver. Im desperate.

1 Like

Pm incoming