Trying to bring my beast back to life (FS esc 6.6 Dual)

Good Afternoon Guys,

Years ago I build an electric mountain board, with the old Turnigy 6364 190kv from hobby king, I went for the FSesc 6.6 Dual (The first version), used it to the point that I had to replace tires because they wore off and punctured the inner tube :sweat_smile: :rofl:

https://drive.google.com/file/d/19ypFd1srQOyCO_A-10cl76oVNdjUc3fW/view https://drive.google.com/file/d/16-BLI5P0wh1X51Q8raIy37M38nN7bso8/view

Fast toward almost 2 years, and today I decided to get it going again for the summer. (Yes I know 2 years is way to much, but between moving houses and even countries I couldn’t enjoy the board as much as I would have liked). Downloaded the new Vesc Tool (3.00) and got a message saying firmware too old you need to update your vesc. I was like “ok, lets just update it”. I am now stuck of firmware 3.53. No matter what I do I am stuck on that firmware, most likely because I tried to go from 3.53 to 5.2.

I think I bricked my dual 6.6. Is there a way to revive it? I have tried to search around and found a couple of topics about “bricked 6.6” but the information is all over the place and I have tried a couple of things but still no luck and I don’t want to make it worse.

Both esc’s connect, both with blue and green lights on. I even tried with the can switch on, connecting the SWDIO pin and the SWCLK pin from one esc to the other to see if I could get anything under SWD Prog in the Vesc Tool.

Any help would be much appreciated.

Best Regards Nesquick

1 Like

Hello Nesquick!

So you are stuck on firmware 3.53? But both green lights are on?

From my experience (not 100% sure), bricked ESC would leave your ESC with only the blue light remaining…

And I guess that your motors are not spinning right?

Did you make the update for the right Hardware version ? (I did the mistake once…)

2 Likes

Good Afternoon @Johnnylamouette

Thanks for your reply, it might not be 100% bricked but it is not working as intended. I do have both green lights on and both blue lights on with the can switch in the off position. The motors don’t pass detection but sometimes they spin. If I squeeze the trigger on the controller they kinda move but very very slow, I looked at the real time data chart and it they were pulling less than 1A.

In regards of the update, I have updated the correct version and even tried a couple of times to make sure and it is definitely stuck on 3.53. I have tried multiple version of the Vesc tool, the one that seems to be working “better” is 1.08 which is the version compatible with 3.53 but still after updating the firmware it stays at 3.53.

Any ideas?

Best Regards, Nesquick

I’m absolutely not specialized in this kind of troubles but I understand the frustration. In this case, I would try everything that can’t make it worst.

Maybe if you didn’t try it yet, do the detection again with an old VESC TOOL, even Ackmaniac version. If you can, try to update again the firmware threw bluetooth…

I hope that you will be able to fix that quickly, maybe someone here has the solution. I would say that your ESC is not dead, and there is a way to make it work!

Once again thanks for your reply. I have tried detections after detections with all the VESC tool versions I could find. Pretty much from 1.06 to 3.00 to no avail. I have tried bluetooth and same thing happens. Tried the Ackmanic version and does not work either.

I am running out of ideas. The last thing I might do is to get an ST Link from amazon and try to reflash the bootloader. But I will need some guidance from someone more experienced to do that. (I found a video that kinda explains it but I am sure it will not be enough because most likely other problems will rise).

Best Regards, Nesquick