Trying to connect hm-10 to vesc app

Hello, i’m having trouble connecting to the android app, i’m using nrf51822 with the uart exemple but i’m afraid that the problem is caused by the firmware i’m using in my board, would you please give me the link of the appropriate firmware?

Can’t use an nrf board sorry

oh :frowning: okey can i have the firmware for windows plz? not in hex form, project for keil or something like this so i can send some data to my nrf via uart another question: cab the hc-05 bluetooth module be used?

I have the same problem, have any solutions? Pls help Thx.

Revive! :ghost:

I got a hm-10 recently and I am having the same problem you guys described: device name “BT05”, can’t connect to app. As a programmer, I am not giving this up. I looked into the open source vesc app tools and found that they all seems to used a piece of code from “Vesc logger”

which is a partial port of the UART library for Arduino. What theoretically was supposed to happen what the iPhone is supposed to act as an arduino and the module as the “wire” connecting the tx and rx.

What’s basically causing the problem for my case is that the UUID of the hm-10 did not match the pre-coded UUID in the app. But even after changing the device and characteristics uuid it still ran into problems receiving data. And since it was written in obj-c, I gave up finding the glitch.

I tried again by reusing my own Bluetooth connection protocol I programmed for a previous app in swift and bridged to obj-c uart data parsing functions given by “vesc-logger” It kind of worked in that I was able to transmit data correctly but only got garbage back. The data wasn’t able to be fully interpreted in the function checking the crc sum. I am not sure if the vesc is acting weird or the data parse is messed up.

If anyone has an iOS parsed library for uart hm-10 please advise sharing. :smiley::pray:t2:

GUYS!!! I figured it out!! :sob::sob::joy::joy::rofl::rofl::confetti_ball::confetti_ball:

The HM-10 module send the Vesc data in four packets and the obj-c library was interpreting the packets consecutively instead of contiguously. After I concatenated every four packets recieved I was able to successfully verify the CRC and read the bldcMeasure. :face_with_monocle::nerd_face::nerd_face:

I’ll be uploading the full demo some where in the near future in github. :cowboy_hat_face:


nicely done @ZackoryCramer :+1:

1 Like

Buttboarder and Bugfinder! No for real, good find :slight_smile: (@Cobber first :hugs:)


so i just got the HM-10 module from longhairedboy, on the site it says to use 9600 baud rate which i tried but it won’t connect. i’ve tried probably 10 different baud rates and not a single one works. the only app that recognizes it on my LG G5 on android 7 is VESC Connect Pro, ackmaniac’s doesn’t work, doesn’t work. nothing connects to the module. RX is to TX and vice versa, the HM-10 just continues flashing forever, what am i missing here?

Samething here can’t connect on any of my boards

i’m talking to support at LHB but they’re just telling me the basics of course, we’ll see if i can figure something out.

Hey I have the problem that i connected my HM10 board to 5v set everythig up baud rate to 9600 and ppm and uart but as soon as i connect my phne no realt time data is coming trouth like it says esc not connected but i set everyting up I use HW 4.12 and FW 3.40 do you have an idea

The app doesn’t support 3.40 yet.