Unable to connect flipsky dual vesc 6.6 to computer

Hello everyone! I am looking for a little advice from some of you who have some more experience with setting up VESC’s. I’m currently working on my first board and just got everything connected a couple weeks ago. The problem I am having is I was attempting to set up my vesc(Flipsky duel 6.6 fsesc) settings on my PC(windows 10) after powering my vesc on I tried to connect it to my PC via USB. Everytime I plug it in it say " the USB device you connected is unrecognizable". Is there something I am missing? Do I need to download a certain driver to get it to recognize? I have tries multiple usb cords and usb slots and nothing helped. I also tried to connect it to my android phone(galaxy s7) via bluetooth and it say my vesc rejected the connection. I am going to try to connect it to my phone via usb when I find my usb to micro usb adapter. I am kind of at a loss as to what to do. I tried contacting the FLIPSKY a week ago and have yet to receive any help. If anyone has a few pointers to what could be my issues I would appreciate it. My full set up is 12s5p battery( samsung 30q), flipsky duel vesc 6.6, duel BKB 6374 190kv motors. Thanks!

Just to be sure: you do have VESC tool installed, right? :smiley: I doubt Windows itself knows how to do anything with regards to ESCs…

1 Like

Yes I do have it installed.

Do you hear a sound when you plug in the usb to ur pc? If not you’re missing some drivers. I think the vedder website has more info.

1 Like

Have you tried using another USB port? Or removing the driver files from Device Manager and then plug in the VESC again>

1 Like

Yes you need the right drivers for sure. Maybe this helps:


I have tried different usb ports but not removing the driver files I’ll look into it thanks!

Yes it makes a sound everytime I plug it in and shows a pop up in the bottom right of the screen that says " usb device is not recognized "

Perfect! I think this lookss like exactly what I need! I will definitely be checking that out later tonight. I bet that’s exactly what I need. Thank you.

1 Like

Unfortunately after installing that it still wouldn’t recognize the vesc, But I ended up paying $2 for the VESC Tool on the play store and connected it via bluetooth and it worked perfectly! So I got my motors set up and ready to go. The firmware needed update and after it still didn’t connect to my pc but oh well, the app seems to do what I need.

1 Like