Unity stuck in full throttle without the remote even being turned on

this happened on @ARetardedPillow custom cgt build, the damn board was on for about 20 seconds and then as I was about to start heading my way to the local park for a test spin the thing just took off with the remote being OFF the whole time.

the best thing was I even managed to capture the moments on video…

so glad it went under a car that was parked and not one that was moving, cause otherwise good bye 2,000$ :frowning:

here is the video of the full throttle on the latest FW



Similar issue?

1 Like

Same issue


Jeff is working a patch to immediately fix this. The metr must not be logging until he does. I’d suggest unplugging the metr while you wait if you want to continue riding.

I was worried bt modules could do that.

But maybe it’s the unity’s fault or maybe the unity is different enough to say that those bt modules weren’t designed for it?

1 Like

Read the esk8news thread, deodand broke his thoughts down for us electronic simpletons :joy:

1 Like

That’s scary as flip,

Looks like I’m sticking to my 25mph, 10s, dual-focbox (1+1) dual receiver board.

1 Like

Fuck! That’s a nightmare…!

Just so everyone is aware a firmware patch is already live as of last night that solves this issue. It has only been reported to occur with unities running FW 23.45 using the internal metr module while logging data. I have identified the change with FW 23.45 that caused the issue and reverted it, so anyone running 23.45 and metr should update.


I actually had the metr unplugged and went for a test ride…

it happened again.


Jeez :no_mouth:

You alright at least?

You need a pair of vescs? someone is selling a pair of 4.xx for 75$ on the other forum… lol

i think i will consider some vesc 4s… are they focbox? cause those have always worked flawlessly.

and yeah, im good, it happened when i got off the board and shut the remote off, 1 minute later the board still on started to accelerate full throttle and wouldn’t stop. hasn’t happened to me yet while on the board with the remote on.

1 Like

Pretty scary :frowning:

Have you tried a different remote?

will do soon,

1 Like

This sounds like misconfigured failsafe on the remote. Can you try to replicate this on the bench? If it always goes full throttle after 1 minute it’s the failsafe. Maybe you can try the remote+receiver test on another board too, just to make sure.


This has nothing to do with unity, stop scaring with BS. THat is a failsafe issue with your receiver. Unity has no clue whether your remote is on or not, only whether it is getting signal or not. When you turn your remote off, the faifsafe signal takes over on the receiver and if you have it preset to full throttle then guess what will happen… If it goes full thorttle after 15 seconds then your receiver is faulty, buy a new one.

1 Like

It’s not the failsafe, he’s using a gt2b, I’ve tried the board out myself, and the failsafe is set up properly

It’s a faulty gt2b receiver. This has happened a few times before.

If he’s using a GT2Be then it is 100% the receiver.

no there was an extremely dangerous firmware coding error during one of the updates in the unity, caused by some type of fault between the built in metr module and the error handling sub routines of the unity. at least 2 different people had to jump off their boards when they went to full throttle (one at around 30mph)… ask @Deodand