Starting Tips | Ask Questions | Introductions | Categories

USB devices Disabled


I am plugging the VESC to USB, with or without power source, and I always get the same notification:

“USB devices Disabled - Unplug the device using too much power to re-enable USB devices.”

I have tired on Mac, Ubuntu and the result is the same.

Anyone has solved this issue already?

Thank you

This might sound silly, but did you try using different cables? I’ve had experiences with USB where one cable works and one doesn’t. Not sure why. Both cables might transfer data, but one might not charge my phone or power up a device. I’d also test that USB port to see if other devices work.

hello sorry for late reply.
yes i have tried different cables of course and still the same. The usb port is not the problem nor the cable.
I removed the cables’s connector to keep just the pins, plugged them upside down and it worked. But i have been told it is not an issue. How come? I dont understand what’s the deal with it.
thank you

Sounds like you have a VESC with the incorrect usb port attached. Upload a picture, let see what we are dealing with.

I am pretty sure it is upside down, but the design on github were like this. Actually, i dismounted a usb cable, wired everything the other way around (pin1->pin5… pin5->pin1) and it worked perfectly. the only thing is that it is not a sustainable technic and might end up breaking the usb connector. Here are 2 pics:

Sweet, you found your problem! You have a couple of options, splice a usb cable in reverse or rework the pcb to change out the port with the correct part. Reworking would require a hot air station.

Can I do it otherwise with bluetooth for instance? reworking the pcb is not in my skills at all.

Just cut the cord and rewire it in reverse if you want to hobble it together, no shame in that. Get it rolling!

1 Like