Vedder fuse switch not working - Chaka revision

Basically, I have the switch connected and there is a resistance change when the button is depressed. But no voltage will pass over the positive side of the switch.

Edit: and yes I have triple checked the wiring, it’s correct.

have you tried bypassing the pushbutton and putting the eswitch into ON position by shorting the switch wires?

Where is the thin red wire attached to the positive output going?

My guess is volt meter, though they should really have both leads for it next to each other. I burned out 2 voltmeters by attaching them too far apart…

agreed. volt meters should have both leads soldered to the output side of the eswitch or somewhere else on the output side.

Since I couldn’t tell which end was plugged in where, i also thought maybe it might be backwards, with the cells plugged into the output side. Its hard to tell in the picture. That would also make it not come on right.

The side without the switch is the output. Since the supposed voltmeter is on the right side, I’m assuming they have it hooked it correctly.

and that does look like the male connector on the input so that backs up your theory.


it could easily be a problem with the pushbutton, which could be tested by shorting the ON to COMMON, or it could be an issue with the volt meter. Not having the volt meter leads on the same side of the switch is an issue, but that could also be a lead for whatever BEC is running the light in the pushbutton.

as an aside, i make these little leads with servo jumpers that can be used to keep the eswitch in the on or off position. I use them to keep the switch off while the packs are sitting around waiting to go in a board so I don’t have to dangle a button or rocker off of it. of course they can also be used to turn the pack on while testing stuff.

Thank you all for your comments the mysterious red wire is going to the LED on the push button(there is a resistor at the contact of the button, I don’t know if you can see that though). I will try shorting the switch without the push button right now.

So I tried shorting the pads and it’s just dead. I was told mosfet die open so I’m sending it back to shogu to see if he can figure out what’s wrong.