Very dangerous cut outs going full throttle after 30mph+

i have the metr pro, but for some reason… it keeps making my settings change and the board act weird. like every time it’s in it makes one motor stop working and the other act crazy, one time it was making a very loud humming sound and i thought i messed them up… thankfully they didn’t.

@rpasichnyk maybe?

More details please Configs before change Configs after change Logs

Is it possible you are pulling too many amps?

Did you checked if you not reach ERPM limit? I have same issue that at high speed sometimes I get ERPM cutouts :slight_smile:

how would i check this exactly? it doesn’t happen at low speeds, only higher speeds when acceleration is super hard

im pretty sure that’s what it is, already bought a set of new motors… can’t wait to get them switched out :grin:

Because motors are not always exactly kv they specified :slight_smile: you can find out your kv after motor detection writing something in console don’t remember now, but at 200kv 4.2V * 12S its already over 60k

1 Like

Well hard acceleration and high speeds definitely pull a lot of amps. A bt module is the easiest way but you probably could plug the vesc into your computer after it happens. I don’t really know how to do this though as I never have needed to

One thing is that bluetooth apps has to inquire current reading and based on update rate you can not see some nasty current spikes coming up. It would be nice if vesc itself would log highest and lowest values of current voltage and etc values and would report it via same status command.

@trampa if you could forward this to Benjamin :slight_smile:

Thought of already…


What is the behavior on the bench with wheels in the air? This way can see if its load related or RPM related.

works perfectly fine, no issues what so ever… it’s only load related, and happened again this time accelerating full throttle from 15mph… it triggered and cut off…

how do I figure out if it’s erpm related or load related?

I think you just did. Its load / amp related. If it cuts out and you plug into pc after without turning the board off there is no errors recorded?

If no then I would say its not the vesc causing the issue, some other component is at play. Battery / BMS / receiver. Sometimes a receiver can be swamped by magnetic interference under load if its in a bad location.

1 Like

No errors recorded at all last I checked, I’ll admit I’m very new to vesc and the software in general so I have not a clue what I’m doing most of the time but looking in the ESC Terminal or bug console, there is no fault that pops up. I’m gonna try checking right now.

as for it being the BMS, the BMS is currently bypassed, so shouldn’t be that. I have a strong feeling it’s only happening under semi-hard accelerations to pass a car or get up to speed for example… rarely does it ever happen going slow or just cruising, but it is a bit frustrating that I have to ride it like it’s a boosted board in eco mode otherwise it may just cut out mid-acceleration and the momentum throws me off. I’ve gotten used to cut offs and I can recover from them if the road ahead is nice and empty, but with obstacles which are common in my area it’s only luck that I recover, most of the times there isn’t enough space to do so.

solved by a simple 10$ receiver replacement…

I recall also getting cut outs after putting my hand in a different position, and overall the connection was fluky at best. So, I figured all along it was this damn antenna / receiver.

Now it works great, 80 miles on it so far in 3 days and not a single issue…

so dang happy :grin:


Do you have some pictures of the board?

this is it when it was brand new

this is it after using it for a few weeks and realizing it’s too damn low, so i restored it some.

and now i have to take updated pics, it’s rougher looking now, but it works better now.

1 Like



I was on the right track! Glad you fixed it and that I could help. :+1: :sunglasses: