Vesc 4.10 "failed motor detection" in BLDC tool


I received my vesc about a month ago and everything was great right out of the box. I had roughly 10 hours of issue free ride time when randomly while cruising I lost full control of vesc. Blue and green led lights remained illuminated as usual. I walked home and plugged in the vesc and opened bldc tool on OS X. With Vesc connected as it should I did a quick run through to see if everything was functioning. I was unable to control motor in experiment so I attempted to detect motor and it displays "detection failed.”

Motor, wires and connectors tested good with seperate esc and multimeter.

At this point Im not sure what is wrong. I fear I may have shorted one of my capacitor leads to vesc board but I figure it would fry everything if that happened.

Do you fellow riders happen to have any suggestions?

My build Sk3 6364 190kv 1:2 drive ratio 83mm wheel Vesc Quantum pistol transmitter and receiver 2 4s multistar 16ah lipo in series

The blinking red and blue lights indicate that indeed one of the caps might be damaged. Can you here a “blistering” noise from the backside of the VESC when you power on/off the VESC?

If so, you just need to replace the damaged cap. The VESC might still work.

Thanks for the quick reply. So far I haven’t noticed any blinking lights. Just a steady blue when I first power up vesc and within several seconds the green led also illuminates. Both led illuminate constant

Does the motor make any humming noises? I found with my 4.10 from enertion i had to re flash the firmware before it would work. I think it was pre programmed for the type r and wouldnt play with my sk3.

Unfortunately no humming noises or movements from the motor. Not even a measure of voltage from the phase wires.

How did you re flash the firmware?

Thanks a lot for your help. I re uploaded the FW and corrected all my settings and still no luck :frowning:

I guess there is something going wrong on the output side of the VESC then if you can read and load firmware ok.

Go over all the soldered wires to ensure everything is well soldered, double check motor wires to make sure all connections are good. no cold solder joints.

Not sure if it’s applicable in your case since you managed to ride it for a while before it happened, but one of my vescs had a shorted pin on one of the big chips by the motor leads, might want to check if that’s the case. Posted a pic of it in my build thread. Might be worth a shot.


I finally found some time to check out my vesc. I replaced motor wires and resoldered connections. visually inspected the board and everything looks normal. No signs of shorts or anything for that matter

still no luck with motor detection in bldc tool

Im getting the same error message, when I try to detect the motor is jerks once, then again 10 seconds later and it gives me this error. Im using the 4.10 VESC’s with the 2.3 BLDC, both have the blue and green lights on. The other motor is fine and its the exact same assembly.

Has this been resolved, if so how?

@jonathanngkh This is a symptom of a variety of things. What do you have going on, any fault codes?

@chaka I posted this on my own thread earlier at

Hi guys, I made some progress today. Soldered the nyko kama nunchuk receiver to the jst connectors and they connect just fine. Soldered the vesc to the motor connectors too, and soldered leads for my zippy batteries.

But I think I fudged up my vesc, really hope not. I was having a lot of trouble with the BLDC, but eventually i got it connected. Motor detection wasn’t working, but then I realised that was because i had my receiver plugged in. So I unplugged it, rebooted and reconnected and ran motor detection.

VEEEEEEE the motor starts going, slows down just like in Vedder’s video, then VSH it starts up and chokes. Next thing I know, the VESC is no longer connected, and the LEDs on the VESC no longer light up, so I can’t connect it.

I had my space cell connected to the VESC, VESC connected to motor. Did it short? Is it fudged? Should I get a new one? If so, how do I prevent the same thing from happening?

So close, yet so far

Did you solve this problem yet ?

And now I find myself here…

@ckaka or any who know how used VESC TOOL not BLCD TOOL hi do you know anything about Vesc tool I need some help to program my Vesc it only works with Vesc tool not blcd,I copy some set set up on YouTube but my brake don’t work down hills image

your setup is incomplete… those boxes should be green