VESC Boot Loader Installation Tutorial

You only need to connect DIO - GND - CLK and power the vesc normally through the battery.

1 Like

If you have one working vesc you could flash the others via can bus as long as you use the newest firmware. I didn’t do that by my own yet, but @trampa for sure can let you know what to take care of if to do so.

And for the st link you can find a „how to“ also here:

Never connect 3.3V on a China ST-Link clone! They fire 3.3V towards the chip, although the pin should be a voltage sniffer only, detecting if the chip is powered or not. GND, IO and CLK only.


Hey @Andy87 @taz @trampa thank you!

I had learnt that the 3.3V pin if connected to Chinesium stlinks only fries VESC6, but is OK with older versions, but apparently not.

So what I gather from your advices is connect the VESC through a bench power supply and connect GND CLK RST DIO? Will give it a go.

No, only GND, IO and CLK.

Not RST.

1 Like

Anyone have insight on how to plug and use the nucleo64? Images on where to pin on the nucleo and where to pin on a flipsky dual vesc6.6 would be awesome. The master side of mine received the wrong hw/fw and I need to flash it back to lifeIMG_20190531_200020523 IMG_20190529_000352970

You can flash the master via the slave. VESC-Tool had a SWD Prog feature. Interconnect gnd, Io, clk, on both SWDs. Open Vesc- tool, connect to working VESC, select SWD Prog menu on the left, hit connect, select vesc six, hit upload.

Benjamin Vedder has a YouTube video up. Just search for him on YouTube.


Didn’t work for @Manu39 and I (VESC couldn’t find target, using FW3.57 on ESCAPE) He had to buy a STLink though.

1 Like

Should work. Both units powered, interconnect IO, GND,CLK, ca. 8cm Long cable.

Should, but didn’t. Everything was set as it. I did it remotely with @Manu39, he has maybe more details to provide.

I hope this helps.

I tried that but wasn’t finding target :frowning: it’s why I went for the nucleo

Btw can I use these one next to another or is the connector too big? I can’t solder a full connector without removing the heatsink

you will need a 5pin JST PH connector, believe me, I tried using standard jumper wires X_X.

Also, uploading video now, will tag and send to you on original thread once it’s done uploading.

Wait, the SWD header is not populated on the dual… hmmmmmm. You might be able to get away with soldering male jumpers. What I really like that Flipsky did is that the SWD pinout on their ESC follows the same pinout on the nucleo board’s ST-link. Some smart people at Flipsky xDD.

1 Like

I am trying to connect to my Fsesc 6.6 but i get this error in the SWD prog screen. Do you have any idea what could be cousing this?15608289824601578189988105241858 1560828999634792459551862789929 I am trying to fix what looks like a bad bootloader on one side of my dual fsesc 6.6 greatly appreciate any help!

You need a working ESC and that needs the latest FW on. This ESC is then used to program the non working ESC. Interconnect both SWD ports: GND to GND, IO to IO, CLK to CLK. Then use SWD PROG feature to recover the non working ESC.

You can also try and upload the bootloader via the bootloader tab in the Firmware menu. If that doesn’t work, SWD PROG is the next step to take.

This is third party hardware and customer support should be done via the vendor.

I’m getting a blinking red light that flashes 3 times after being connected by ST Link. Nothing else is connected to the VESC, any ideas? it’s a VESCX, my other VESCX connects just fine but not this one.

Did you find a solution. I have the same dual esc and changed one STM32. Getting the same error message …couldnt connect to target. The STM is from my miniquad with Betaflight Bootloader.:thinking:

No I never figured it out, just gave up on it and ordered a metr pro