Vesc controller woes

Fried my first drv on the vesc, so I got a new one and everything was fine for a few weeks but after hitting a pretty solid bump my board died. I checked it out and the vesc doesn’t turn on at all, the LEDs don’t shine. I get voltage at the terminals on the vesc and it sparks when connecting. I tried to test for 5v at the connector next to the copper coil thing (don’t know what it’s called) and it doesn’t seem to have voltage there, the multimeter reads something like .21v. Whenever I plug the battery in the copper coil gets extremely hot after a period of time. What could have happened? Really don’t want to buy a third vesc


While I can’t do much about the issues with your DRV chip (other than offer to fix it or tell you who can), but I have seen a few issues with the the L1 inductor (the only thing I’d call a big coil thing) Where did you get your VESC(s)?

I bought it from a member on here, it worked for a bit but then stopped… this vesc pictured the drv is fine, the other old one is dead in a box. Do you think I should just replace the l1 inductor or something else is wrong?

It may be possible to just replace L1, but its pretty difficult to say if that’s the only problem. Do you know the original source?



From what I can see those PWM wire aren’t insulate… witch mean that if you hit a big bump, they might move and short together, resulting in a dead VESC… Might be the drv since this is the part the give the 5v to the hole pcb… But It might also be the Can transceiver, since it’s really the weakest link in the vesc, you can test it with the following procedure.

1 Like

Wow good eye! I did not see that.

I checked the c25 capacitor and I get something different then the leads connected (was a value like 5-600 instead of 000 when connected). Does that mean it’s the drv chip? When my last drv chip fried the vesc LEDs still flashed and turned on. Yes the ppm wires are not insulated… I was excited to get it working I got sloppy and soldered the wires into the male connector instead of buying a female to female cable. Thanks for the help

Sadly… It look like the DRV burn…

Different failure, will give you different result… Like if you short motor lead, there some part of the drv that could still work, like the internal regulator, but if you short the regulator (like in this case) drv won’t even power up, resulting in a dead VESC.

Well… I messed up my first drv repair, perhaps this one will go better. I had barely soldered before that but now I have much more experience.

1 Like

Do you have a hot air gun? That’s what made the difference for me on that particular chip.

I do indeed have a hot air rework station, my problem is I put the chip backwards. Then when trying again, I couldn’t get it exactly on the pads

1 Like

Well, I have successfully swapped the drv chip, and the problem is still here… Any idea where to start next? Possibly swap the inductor?

No LEDs inductor still gets hot

Clean up the drv pins with flux, there is what seems to be a ton of whiskers

Check if your 3.3V rail is shorted…

Like hit it with the gun and some light flux? I just don’t want to apply too much heat and it fall off. Where would I check the 3.3v rail?

No clean it up with an iron, put flux and touch pin by pin.

For the 3.3V… check the connectors, its marked on the silkscreen

So when checking the 3.3v and using the gnd it’s not shorted… However I made an interesting discover. When checking the c25 capacitor the capacitor was not shorted, so I assumed 5v was fine. But when checking the 5v and gnd pins I get a short…

Ok, we’re getting somewhere, clean up that drv before replacing anything else

I think that might be glare from my light off of the flux, I hadn’t cleaned the flux off yet. I tried to clean it up but doesn’t seem like much is different

Using a parts vesc, I swapped over a spare can transceiver (u401) AND swapped in a new drv and still shorting on 5v. Getting the exact some problem from the start, and inductor is still heating up when battery is connected