VESC | does not connect or stay connected on ubuntu or windows

I’m not a noob to computers, coms, serial, or usb. I’m a total noob to VESC, however, and this is the first time i’ve tried connecting one to BLDC tool.This is an Enertion VESC that went out with the most recent batch. I keep seeing how “easy” this is and figured most of the uissues would be ironed out by now, so maybe i’m doing something stupid.

I have the VESC powered by a DC power supply set to a max of 22 volts. It can only draw 5 amps from this unit. Should be plenty for bench testing and motor detection.

I installed the windows bldc tool and usb/serial drivers it came with. I made sure nothing was plugged into my serial port (i have a smart power strip that i use on my desk). I Connected the USB cable to the VESC and my PC. plugged in the motor phase wires. The default connection is set to COM3.

I click connect and it says DEVICE NOT FOUND.

I switched to COM2 and got the same thing.

I switched to COM1 and it says CONNECTED, then after a second or two it says NO FIRMWARE READ RESPONSE. and then says Not Connected again.

As soon as its powered on, the blue LED begins blinking rapidly and just keeps doing so sort of like a hard drive light does when its reading.

Before i tried it on windows, i got the same issue on Ubuntu. DEVICE NOT FOUND every time i hit connect no matter what COM i was using.

What am i doing wrong here? I tried both VESCs thinking maybe one was just bad. They both do this.

Open up Device Manager in windows and check to see what Com port it is actually using instead of trying to guess. Mine was on Com7. Plug in the vesc after you have device manager open and you should see it pop up on the list.


i rebooted, then reconnected the VESC thinking i had a com conflict and then went into the device manager and powered on the VESC. I’m still only seeing COM1 in the device manager. ITs as if the drivers for the virtual COM ports isn’t working right. i reinstalled the drivers, still no dice.

I tried three different cables, one of which isd a known good USB data cable and not just a charge cable from an old device.

This hurty my head.

just uninstalled the virtual com port drivers that came with the windows bldc tool from onloop’s google drive link and tried some different ones from someone else. Still nothing.

Is there possibly some kind of version conflict between the tool and the VESC? It looks like the tool is version 2.5. I have no idea what version of anything is on the VESC since its not written enaywhere on the board and I can’t get it to connect and tell me. .

I’m going to try setting up my VESC from enertion’s batch either tonight or sometime tomorrow. (I’m on windows aswell)

I recently set up the one I got from @chaka, so I at least know my software is working- from there I can see what’s possibly different about this newer batch…

I think the BLDC tool I currently have is 1.14 if I’m not mistaken; or whatever the latest one was before FOC.

So do enertion’s new VESC’s come with the firmware for FOC, or are they still rocking the older stuff? could using a new BLDC tool with an older VESC make any problems?

just spitballin here because I know basically as much as you do about VESC stuff…

Hope you get it sorted out

1 Like

My Vesc’s from Ollin came with 2.4 and then I was prompted to update the firmware as soon as I connected them to 2.5. It took a few trys and some fumbling to get them to connect though. I would click connect, nothing, connect, nothing , connect, nothing…and then it was like “hey man, what’s up?”

1 Like

ok i had the same problem. i cant figure out how to install firmware for 2.5 with windows so if you want to get up and running without foc… just download bldc tool 1.14 since that is what is installed on your vesc right now. no foc but you can at least ride and test it.

1 Like

Here is the older version of BLDC tool. This is compatible with the firmware that is installed on the last batch of vesc.

Also. I don’t know if this matters… but I have never had to manually install the STM driver… windows always detected and installed the driver automatically. I have lots of usb ports so normally I’m on COM12.

I have never had a problem with connecting this way

1 Like

I just downloaded the 1.14 version and i’m still getting the same issue. Windows just isn’t seeing the device and isn’t having any reaction to it when i plug it in or unplug it. Nothing pops up in device manager and a manual sweep across COM1-20 doesn’t allow me to connect. BLDC tool only reacts to COM! and then after a few seconds of saying its connected, it tells me it can’t read the firmware.

I wonder if the fact that i have an actual, physical serial port on com1 is causing a problem. I’m going to disable it in the uefi for now and see what happens.

Did you try to install the driver? I had to install one to make it work. The driver install is in the “bldc-tool-windows-drivers” folder

the first usb port i tried has been acting up and wouldnt detect it so i had to use the one on the motherboard. when i did that windows update downloaded chibios and i was golden at that point. worth a try

yes. I installed, reinstalled, unistalled then reinstalled, rebooted after reinstalling, disabled my actual serial port in the thinking there may be a conflict, i got nothing.

I even tried a different USB COMs driver, the one from FTDI. Still nothing but “Device Not Found.”

So far i have 2.5 and 1.14 on windows and neither will connect to the vesc. I also have a laptop running ubuntu where i previously did a make/make install compile of BLDC tool for 1.14 and its no worky there either. On that one it just says “unknown error” when i hit connect.

I have tio be doing something wrong and i’m sure its something stupid.

On the VESC the blue LED is blinking very rapidly and there’s a tiny orange LED right next to it that’s just barely glowing tinyest bit.

I havn’t tried a different power supply. I’m about to try that now.

I did it with my space cell. I had a blue and green light not blinking

@kai that clue regarding the not blinking just confirmed a suspicion i had… and that suspicion confirmation may have just been backed up by what i’m seeing now.

I’ve already torn apart my space cell, but luckily i have a whole mess of alligator clip jumpers to tie everything back togethr temporarily.

I’ve got the space cell powering the VESC and i no longer have blinky lights, and Windows just piopped up a message about a device being on COM3.

Hold your breath… i’m about to hit the connect button.

1 Like

well hot damn i’m connected.


Motor detection just happened!

Thanks guys for the assist.


I was using one of those PS-305D DC power supplies. I don’t know if maybe i wa using it incorrectly of if the PS literally stands for Peice of Shit, but i will be doing more resaerch into why it didn’t do its job today. I bought an extra one for my 14 yo son to play around with since he’s getting into electronics and stuff. I hope i didn’t make a mistake in doing that.


did you crank the current to the Max setting?

I thought I did but I may not have, or I may have reset it at some point. I’ll have to play with it some more.

Just got my 2 new VESC’s and i am having the same problem. i know this is an old post but i thought you’d probably know more than me. i am using two LiPo batteries in series, i know its not ideal for configuring the VESCs but its all I’ve got. i don’t have any kind of power supply. it only connects on COM1. was wondering what i could do to fix it

1 Like

I got the same problem (no firmware read response when connecting vesc). When I try to install the drivers that come with the BLDC file they fail to download/install. Anyone got some advice?