VESC Drivers Install Fail

Hi Guys,

I was having some intermittent issues with my board today on my way to work. It would stop working, almost felt like brakes kicking in. Then if I were to hop off and try the remote again it would go to spin the motor and jerk. If I left it for a minute or two it would run again. I would be able to push off and travel again for about 100ms and it would cut out again. I think this is an issue with heat. So I’m at work and trying to use the BLDC tool. However the drivers don’t seem to be installing for some reason. Has anyone had this issue and fixed? Or have suggestions?

I tried rebooting etc and tried installing the drivers using the installer in the BLDC folder and got the following:

Thanks :slight_smile:

Always use a USB 2.0 port. Don’t use a 3.0. Sometimes, you can change the driver. You’ll kind of have to play with it until it works as it does depend on the computer your using.

1 Like

Hi bud, that might actually be the issue. I’ll move to another computer later as my work laptop only has usb 3.0 and didn’t realise that until now. It amazes me that all 4 ports are 3.0 when so many 2.0 devices aren’t compatible with 3.0.

Yeah, definitely. I do think all these devices are more legacy type devices though. Most new devices should be fine with 3.0 but yeah… it is annoying especially on a laptop to have nothing but 3.0.

The other issue is DACs as some can have interference from using USB 3.0 I might even look in the bios if I can force 2.0 mode on one of the ports.

curious- is this USB3 limitation the same on the mac version?

if no one can confirm this I can test this as I have access to a mac too :slight_smile:

I programmed my VESC using iMac 2013 if that helps.

but did you use USB3.0 ports?

Yep. They all are USB 3.0.

looks like @t1m0007 got his answer :slight_smile: thanks bud


thanks all

I still couldn’t seem to get this to work. I tried a laptop with USB2.0 but it is also windows 8.1 where as my home PC (which I used last night) is windows 7 and USB 3.0 worked… I would be willing to bet it’s more a chipset limitation rather than anything to do with USB type. Either way I solved my problem (bad connection on motor to VESC, I was getting ABS_MAX_CURRENT)