VESC DRV8302 Fault while testing UART Control

Hello, I made a RX/TX from two Arduinos. The receiver Arduino was connected to the VESC through UART. I used as library. I controlled it through Nunchuk Packets. Everything worked. But then, no movement. Connected the VESC to my PC and low and behold: FAULT_CODE_DRV8302 So I immediatly looked at the VESC if there is visible damage to the DRV chip, but nothing. Checked if it was hot, also nothing. I’m totally confused as to what caused the FAULT_CODE_DRV8302 and I don’t know what to do now. Never got to ride the board, because I had no working remote.

Its an 4.12 Enertion VESC, so you can imagine the frustration, I was waiting for it since april. The VESC worked fine after initial Motor Detection and controlling it through BLDC Tool and when I still used the Arduino connected through PPM.

The complete fault:

Fault            : FAULT_CODE_DRV8302
Current          : 3.1
Current filtered : -0.2
Voltage          : 38.39
Duty             : 0.01
RPM              : 0.3
Tacho            : 5
Cycles running   : 3
TIM duty         : 377
TIM val samp     : 193
TIM current samp : 25865
TIM top          : 51344
Comm step        : 4
Temperature      : 31.99

Here’s also two pictures of the VESC: (imgur because they are to big/high res)

Try re flashing the firmware. That has fixed a few issues for some people.

In the nunchuck pins it looks like ground is connected to the +5V pin. You are sure that is correct? Black cabling should not be used for anything but ground.

I reflashed the firmware, still same problem. The cables are right, triple checked before powering anything on. Used black cable because I tried a Logic3 Nunchuk first, which has red as ground and black as +3.3V, reciever of that was faulty, so I just resoldered the black cable to 5V (5V arduino), and connected the rest of the Arduino.

What is uart control?