VESC DRV8302 Fault

Kind of over the constant barriers I have with just having a simple eSk8. Can anyone please tell me how to fix this issue or even what ESC I can use in place of the VESC using SpaceCell Pro 3 (10s3p) and SK3-6372? I don’t want to have to wait for the week or two I will now have to wait for my other VESC because of the PoS postal service that Enertion uses sent my VESC to the other side of the country. I also don’t want to order another one because I don’t want to have to deal with the postal service Enertion uses. Here’s a screen cap of realtime data (moto detection fails)

Looks like your DRV is fried, could you take a look at it and tell us if you see any burn marks on it? Mostly likely you’ll have to get it replaced.

some DRV faults can be resolved by a simple reboot, some can be related to connection problems with your phase wires, or a bad motor detection, please rule out the obvious stuff.

Please post some photos, also check the power wires are not shorting the pins.

There are about 11 different things that can cause a DRV error.

Is this an Enertion VESC? What country are you in? Did you buy the VESC Platinum? You might be interested in buying the platinum warranty separately & we can send you a brand new unit.

no obvious burn marks, I also tried without a connected motor and got the same result, does the same error happen if no motor is present?

looks like the motor case has been cutting into the wire unsulation. I will check out possible shorts. It’s enertion, not platinum, Australia, if you check out my topic about courier companies you’ll understand the frustration is more directed to Couriers Please that you use. If I order another off you could I pay the difference for express Aus post?

Have you tried rebooting like onloop suggested? You could try re-flashing the f/w (if you know what you’re doing). I would imagine it would still error without a motor.

See this thread, very important!

reboot is turning on/off yeah? I have no issue with flashing firmware, it can be done via USB yeah? Also will I need to backup my XML to apply settings or will I need to re-do it all?

You could back up the XML, but it shouldn’t be too much to reconfigure. You can do it on the firmware tab in BLDC tool.

Already know about that, the VESC I have was to replace my one that had this issue before onloop knew about it

how do i know the version of vesc I’m working with (most recent from enertion) is it 4.8?

Should be 4.12, but it’s printed on the PCB itself.

The firmware version was 2.18, but all the firmwares I seem to be able to get all read as 2.15 and BLDC tool stays in limited connection

hardware version and software version are different. New Enertion VESCs should be h/w 4.12 and f/w 2.18. If you flash the wrong version for the hardware you might brick the VESC.

Not sure what you mean by having 2.18 but reading as 2.15?

I know that. Sorry I wasn’t clear. My HW version is 4.12 I originally had 2.18 FW on the VESC before I did the re-flash. I used firmware that came with my BLDC tool (2.17/2.18 compatible tool) and each of them are reading as 2.15 FW I went to Vedder’s site and downloaded the 2.18 zip file of firmwares and each of these are reading as 2.15 Is there something I’m missing? Could you possibly attached a confirmed 2.18 default firmware please?

Download from It should include a folder with a bunch of f/w’s for different revisions.

The firmware version and the bldc tool need to align, they need the same number

If you have firmware 2.18 get it here, thats the latest

If you have firmware 2.15, you need the 2.15 bldc tool, get it here

I think it was just a tool error. Looks like I had to close it and open it back up again for it to get the correct firmware. Not sure why… Should any of the three phase wires have a connection to each other? I ran a circuit test and all three are positive for a connection

Yes and no, connect them, if your motor runs in the wrong direction, flip two wires

Sorry thought it went without saying. Flashing the firmware I still have a DRV fault