VESC experts: Please approve my DIY VESC lest I blow it up

Hey guys!

I recently got into SMD soldering and thought I would build a VESC. The first one I built blew up right away- as soon as I gave it 12V (0.3A current), I saw some interesting sparks on the DRV. I reckon the failure was due to using solder paste and not cleaning it, creating short circuits on the DRV. Anyway, lesson learned, here is my brand new VESC. Before I power it on, I want to run it through the experts here: @chaka @trampa @onloop @longhairedboy (anyone else?). Does this look good? Oh, and one question: All LEDs seem to work when tested with multimeter, except the blue LED. I tried to replace it, took a new one that worked on the table, but as soon as I soldered the new one, it stopped working too! Weird. Anyway Im thinking I dont need the LED (I ran out of them, and order takes time), so the question is, is there an LED bypass on the VESC? Or will it cause an open circuit where the LED is? Pictures attached below: IMG_20190520_110943 IMG_20190520_110926 IMG_20190520_110916

Thanks guys!

2 Likes

Not an expert about the VESC, but there are 3 bent pins on the DRV (well I think it’s the DRV, long SMD chip on the first picture). Looks like those pins might not be in contact with the right pads.

There are 2 bridges on 2 pins too on the same chip (but that might be on purpose I guess).

There are a few problems, addition to the 2 noticed by @louwii I think you’ve put one of the mosfets completely off it’s footprint by one pad:

image

1 Like

Two pairs on the DRV is s’posed to be bridge, so thats probably them on the lower part of the picture. I recommend that you inspect both the DRV and MCU with a sterescope before you try to run any power thru. Use plenty of flux. Are you sure the LED is soldered with correct polarity?

I can’t remember the idle current of the VESC but try to use a current limiting DC-box when powering up the first time. 100mA should be more then enough for a VESC without any FW on it.

1 Like

Thanks @linsus and @bluegreen Yes, those 2 pairs of pads that are soldered together are the ones that are supposed to be shorted. As for the other pins that @bluegreen highlighted on the DRV, those are bent, and I cant seem to straighten them (Im afraid it will lift the pads from the board if i push it too hard). I checked with a mulitmeter and they arent shorted. Still, do you think I should take off the DRV, straighten the pins, and resolder? As for the MOSFET, yeah it seems to have drifted off while reflowing, but does it matter? I mean all the pins are connected to the same pad end of the day, isnt it? Thanks again guys!

I would resoled both the DRV and the mostfet. The leg you soldered incorrectly is the gate pin. It is not electrically connected to the other ones.

1 Like

Yeah good advise. Will re-do those two. Thanks!

it is the correct color to go fast.

4 Likes

So I redid the DRV, and the MOSFETs, I connected the power cables to 12V powersupply. All was good for about 2 mins and then some burning smell, and little sparks between some pins of the DRV…again. At this point, I dont know what I am doing wrong. I have one last DRV to try, and I wanna make this count. I am going to clean the board, redo the DRV, triple-check for shorts/ solder bridges. Any other advice? PLEASE let me know. Thanks!

Which pins? Are there shorts to ground on any of the power supply rails or phase connections?

No shorts that I could see! I will get a photo when I get home.

Please us a current limiting supply and u wont have to burn thru your chips.

1 Like

@linsus thats the surprising part. I did! 12V and almost nothing in current. 0.3A maybe. Im lost.

Set the limit to 0.1A, and did you probe around with a multimeter?

1 Like

If it didn’t blow up immediately then it’s probably not a dead short. What it sounds like is maybe one of the resistors is installed with the incorrect value or maybe a diode is the wrong way. You’ll have to check each component with a multi meter if there aren’t any visual problems.

1 Like

Update: They say 3rd time is the charm. This time I desoldered the DRV, cleaned the damned board. Got a new DRV on, checked for bridges. Checked with a multimeter for bridges. Rechecked then triple checked. Then i cleaned with a lot of alcohol, and connected to the power supply and hid behind my desk to hear an explosion…no explosion. Hurrah! Successfully booted and programmed. Thanks to everyone on this thread!

6 Likes

I need some help with the setup to use the vesc, does it run on hub motors?

Wich vesc tool have the latest firmware?

You should open a new discussion since this is not related to the topic. Anyway, yes vesc can run the hubwheel. Just download the latest tool from vedders website and it will have the firmware needed on the connections page.