Starting Tips | Ask Questions | Introductions | Categories

VESC FAQ | Firmware Bug | Pre August 2016 | Please Upgrade

The community has found that there is a bug in the current firmware that was shipped with your vesc before August 2016. But good news we have found a solution and want to let you know how to update your firmware. Also, all files at vesc.net.au have been updated so when downloading BLDC TOOL don’t be afraid of getting the wrong firmware.

We recommend you do this now or when you receive your vesc.
If you have a raptor or an enertion r-spec motor don’t worry, the motor setting have already been applied for you.

Please download the new firmware for
http://vesc.net.au/BLDC-TOOL/Firmware/VESC_4.10_default.bin

You will need BLDC TOOL to update the firmware that you can download from
http://vesc.net.au/download-now/

1 Like

What about batch 1 Raptors, mine was back in for repairs mid April. What issue does the patch fix?

if your raptor is working don’t do anything… the bug appears when you are making/applying changes in the BLDC.

So if you do makes changes under bldc tool you have to update to the new firmware.

Are you sure this works the link doesn’t work and I’ve tried downloading the firmware that was updated August 15 and still have ramp bug

what kind of bug is that, what happend when it don’t get fixed?

You blow up your VESC…
The bug is in one of the advanced features, it’s a setting that keeps taps on your power ramping. Aka, lightly ramp up the current instead of hitting it in the face.
But it only come in the moment you read the settings from your VESC and write them back. If you don’t plan on writing any settings to the VESC you’re sweet.

1 Like

Wait so I got mine about the 29th of July and I haven’t used it at all yet should I do this before I use it

Yes you should

Just to be sure

Did the file “/VESC_4.10_default.bin” get deleted ?
I get “Oops! That page can’t be found.” message.

Ok thank you

1 Like

Same here!

@onloop ? could you inform us…

Hey guys, just watch out because the August Enertion VESC’s still have this problem. I ordered 2 mid August and they both have the current ramping bug, so don’t think that because it’s August that your VESC won’t have the bug. Really watch out because it’ll fry your VESC.

Hi, should the new firmware solve the “Max Current ramp step” problem? I downloaded it and gave it into the firmware folder. I opened the BLDC Tool and choosed "VESC_4.10_default.bin. Then i pressed upload. The green bar starts to run till 100%. It writes “FW Upload Done” and in the same moment on the button right it appears “Device not found” and then “Not conected”. I connect again and the bug with the “Max current ramp step” is still there. I tried it many times but it doesn’t work for me. What’s wrong? Please help me!

Hi!
That firmware link http://vesc.net.au/BLDC-TOOL/Firmware/VESC_4.10_default.bin
is not opening, it shows that it’s VLC media file, and VLC player not opening it anyway. About BLDC tool, in this link http://vesc.net.au/download-now/ down load botton for windows is not working, but i tried to click on Old Versions, than click on Parent Directory, than click on BLDC_Tool.exe. Is this BLDC_Tool.exe is fine or it’s bad?
So i have enertion VESC, ordered it in middle of August, now it’s in shelf,never was tried it because i’m waiting for my remote. So when my remote arrives i’ll be doing VESC programming, so i need to be sure what BLDC TOOL to use, where to get it, also where to get that bugless Firmware, because those links not working. Also question about power supply for first connecting to PC, so can i use 8s lipo, if my set up will be 8s? Or better use 4s lipo? Or never use lipos for programming VESC?

My problem with the firmware update is solved. I remembered I had similar problems with an other ESC a few years ago. So I tried like last time to install BLDC Tool on the account of my wife ( same computer) and now i can update the firmware. I dont understand why it is not possible on my account but now I can do it with my wifes account and I’m happy. Is there a computerfreak and can explain me the reason?

@ninja Your firmware link works. You have to download it and then copy it into the firmwarefolder of the BLDC Tool. The BLDC Tool software I downloaded from here: http://www.esk8.de/tutorials-d-e-f/
Don’t use the “Depugged Firmware 2.18 for …”, it doesnt work, use your firmware link " … 4.10_default.bin"
Power supply: I’m not sure about this. I used a 3s Lipo with antispark xt90 in the pluswire.
Some say it’s just a problem when the VESC gets power the first time. Vesc from enertion are already have seen power I think.

O.K. i downloaded that BLDC TOOL version 2.18 for windows from http://www.esk8.de/tutorials-d-e-f/. But when i click on http://vesc.net.au/BLDC-TOOL/Firmware/VESC_4.10_default.bin, it’s downloading as VLC media file, also VLC player not recognize it anyway. Is some other place i can get that firmware from?

The right firmware is included in the bldc tool zip file on esk8.de. Also, the stand alone debugged version 2.18 for VESC 4.12 works too, I just checked again.