Starting Tips | Ask Questions | Introductions | Categories

VESC FAQ | OSX MAC APPLE Version of BLDC tool

@siggs3000 are you using the correct version of BLDC Tool? If the firmware on your VESC is older than the BLDC Tool version that you’re using (1.10, 1,12, etc) you’ll have issues (although I’d be surprised if this is causing a connection issue w your usb port).

I believe so. I have the newest Enertion VESC and the BLDC build from the link at the top of this thread.

@jacobbloy might be able to help you with this, he uses mac.

make sure the vesc has power running to it from battery or dc power supply, then plug in usb, it should detect.

on windows it normally needs to install a driver for the ST chip, then its ready to go.

try a few different usb cables.

I’d also try switching out the USB cable if you can.v know I have multiple different usb B cords, and not all of them work with the VESC, or my camera-

They are more than just power, but for some reason, there are just some that don’t play nice with some of my devices…

I’m on OSX too by the way

@siggs3000 Change the port from 261 to 301

When I did the pull request on git the standard was 261 so I set that for default I’ll look at changing it or adding a drop down box, if it ever doesn’t connect you need to check the port in terminal.

Open up terminal copy this code

CODE: SELECT ALL
ls /dev/tty.*
to find the usb device name it falls under a usb bluetooth device but you will see it like this
CODE: SELECT ALL
screen /dev/tty.[yourSerialPortName]
copy and past it into BLDC tool in the port section and click connect!

standard are /dev/tty.usbmodem261 or as i said /dev/tty.usbmodem301

i have added a read me file to the OS X FW1.14

FW2.0 will be out soon i have a copy of it along with BLDC TOOL but vedder is still making a lot of updates with FOC as soon as that is out i will update OS X and WINDOWS BLDC TOOL

4 Likes

Thanks a million, @jacobbloy

I ran ls /dev/tty.* and sure enough it was port 301. I updated the value in the connect field to /dev/tty.usbmodem301 and I’m connected and on my way. Firmware recognized and all.

Hope this thread helps some other Mac users out there. Thanks again!

3 Likes

@siggs3000 your welcome!

Im new to this community but I was wondering if you guys could help me out.
I currently have the most recent El Capitan 10.11.1 software.
When attempting to open ._BLDC_Tool FW1.14.app I get the error message “You can’t open the application “_BLDC_Tool FW1.14-3.app” because PowerPC applications are no longer supported”

Is there a simple fix for this or am I required to dual boot with linux or Microsoft?

On Mac the first time you launch it you have to right click it, then press open when the dialog box opens. Then it will give you a warning, just say ok and you should be good to go.

Do you have it in the applications folder when launching?

A lot of applications are running into this issue on El Capitan. Don’t move it from it’s download folder (don’t put it in Applications) and then right click and choose “open” on it and it should work. After you run it the first time, you can move it into Applications if you want and that should be ok.

I have El Capitan. I downloaded it. Opened it. Allowed it. Error. Move to Applications folder. Works!

Oh nice. It was opposite for me and the same error for Spotify. Looks like @lox897 way works for this one!

Yep! Try my way! Hehehe

Thanks everyone for the help. I am still unable to open BLDC tool unfortunately. I attempted to open the file as suggested and still the same issue.
I noticed there are 2 folders to choose from after unzipping. One named __BLDC_Tool FW1.14.app and the other named BLDC_Tool FW1.14.app so I tried the second one and now it displays BLDC_Tool FW1.14.app quit unexpectedly

I may just wait until I have access to a PC because I feel it may be an issue with my computer

I used the OSX BLDC tool for the previous version(because I just downloaded it, and it worked without any troubleshooting), but then dug out my old windows laptop to use version 1.14.

It’s not that I don’t like the OSX version, it’s just that so far I’ve heard tons of people say the windows version “just works”, while the OSX one takes a little more fine tuning here and there. And it does just plain work by the way… even on my super old p.o.s laptop, it ran just fine.

litterally, if you just download the windows BLDC here:


it takes less than 10 minutes from downloading the file, to setting up your VESC. There is one driver (needed to run 1.14) that you need to install (easily labeled in the “BLDC Drivers” folder), and then it is just running the program (again, super easy to find) and you are in business!

Is there any way of setting port 301 by default, other than recompiling the code ?

Yes, as I set the default to 261 originally.

In the source code, open main window.cpp

The do a find search for /dev/tty.usbmodem261 then replace 261 with 301, but next updat I will change it to 301, or implement a way that it tries both.

Please download FW2.8 again, Iv added a second field, so if the first fails then the second is tried, please download it and test it.