Im in the process of building my first electrc skateboard so I am new to this. Everything was working perfectly until I brought the board outdoors for the first test when the motor just would not spin. I took it back inside and the vesc gave me fault code ABS_OVER_CURRENT and i could not get it to work, even after tweaking the current settings (Running in FOC btw). After letting the board sit over night I tried to re-configure the motor and it works perfectly again for a couple of minutes and then the motor stops spinning and i get the same fault code again.


This is the latest fault code I got and here are my settings:

image image

Currently i get the fault code while trying to measure the flux linkage, that is why it is set to 100,000 mWb.

Flipsky VESC 4.12
Flipsky 6374 190kv 3250W
12s battry

What VESC do you have?

Sorry, its a Flipsky esc 4.12

4.12 hardware is not so good with FOC, some faults with bad capacitance choosing and FET choise . Go and try BDLC.

1 Like

Im having the same problems with BLDC. I will go test again and come back with results

While trying to detect the motor in BLDC:


I still have the same current settings. The motor twitches once and then the vesc blinks red, nothing happens for a couple of seconds then the motor freaks out.

Set absolute max current on 120A and you are ready to go. I had 90A on my focbox and also had over current. After I switched it to 120A (default setting) the fault was gone.

Btw: run your vesc in blcd

1 Like

And also, according to the real time data, the vesc (or motor?) is drawing ~0.1A while not doing anything… Is that normal? Since i dont remember it doing that in the beginning?

@pjotr47 This is in bldc with abs max current set to 120A


Do you have a fault code while motor detection?

then try absolute max at 130 or 140a

Yes that one is from the detection

Is it really that easy? Sounds like I could just set it to 200A then?

I would first check my connections. Abs overcurrent can come from a bad solder join or one of your plugs or bullet connectors not 100% plugged in. Also check the pcb of your vesc. Can you se find some lose connections? Have a special eye on the legs of the capacitors. If there is something lose, broke it might be the reason.


Oh if that abs over current happens while detection, I think your drv is fried

Try this

Unplug both of the motors if dual setup Swap them, plug them back, make sure joints and connectors are properly connected Set the values to lower, your ESK calculator for that Perform detections, and throttle check then

ABS_Overcurrent occurs when one or more motors are faulty or values are not accurate for the setup.

You have it set to 120 and it went 123 so yeah the fault gets triggered.

Of course you should only be reaching these amps when under load on take off usually.

Ate you running dual motors? Which firmware version are you running?

1 Like

But wouldn’t I be getting a DRV error also then?

Did you have any luck solving this @affeandersson? My VESC has the exact same problem: applying any throttle results in the motor stuttering once or twice, then the red LED blinks and a FAULT_CODE_ABS_OVER_CURRENT is logged. Motor detection also fails. I’ve tried a few different motors with the same result.

Nope. I contacted Flipsky on facebook but they where not much of help so ended up upgrading to a VESC 6.6 instead and didnt have any problems yet…