Vesc firmware issues

I have a maytech vesc 4.12 from that i have been using for a single drive,( 12s lipo 168kv sk3) without problems for about a year now. But now i am uppgrading to dual. I got another maytech 4.12 and another motor, tb trucks motormounts etc. I went to uppgrade the firmware on the vesc’s to 3.4 using vesctool and on the new previously unused one, everything went fine, uppgraded firmware did motor-detection and everything else.

But when I try to uppgrade the firmware on the vesc i have been using for a while (previously 2.18) the uppload seems to go ok, but a the very last second it disconnects saying “No such directory exists” or something similar. After that i cant connect to the vesc again until I turn it of and on again, at wich point it connects and still shows the old 2.18 firmware. And with the old fimware i cant change any settings in vesctool wich is a problem since i plan to connect the vesc’s to eachother via canbus.

I have tried uppgrading the firmware both using vesctool and ackmaniacks vesctool but the same thing happens. If i start up the old bldc tool i can make changes, run motor detection and such but I’m scared to connect the vesc’s on canbus when they are on different firmwares.

Does anyone know why this is happening or what I could do to solve it? I guess i could try to find 2.18 fw for the other vesc and downgrade it using bldc-tool but i would much rather run them both on 3.4 fw. Is it okay to have two vesc’s on different firmwares?

1 Like

Your ESC probably has no bootloader installed. You need to upload the missing bootloader first. Vesc-Tool has a bootloader upload funktion in the Firmware section.


1 Like

Where did you get your first Vesc

Op mentioned that his first vesc was from eskating

But some Vesc don’t have a bootloader

True, like the flipsky’s vescs

Thanks for your help, just uploaded the bootloader and everything works great now.

I’m facing a simelar problem with same Vesc’s dual setup loangboard did you use esc tool to upload the bootloader? if so did you use the bootlader opton in the tool as below?! bootloader|584x106

was serching and reading for a while :thinking: :roll_eyes: i’'ve updated my vesc’s using ackmaniac esc tool, from Fw 2.54 to 3.10 even thoug it’s the latest updat in Fw to my knoulge, but found out fw 3.10 it wont work with controller that i got for dual can-bus connection :smile: tried few times changing thes vese fw to 2.18 still can.

can you let me know how you did? I’ve might missed somthing?