VESC gurus, please help!

Hi guys! :slight_smile:

I have a problem I’ve never encountered before. I just got a new VESC 4.12 from TB for my dual motor setup.

Last week I upgraded the firmware on my old VESC (also from TB) to 3.54 with the latest VESC Tool and it was seamless. Now that I try to upgrade the new VESC it says that my firmware is too old, just like the old one. But when I’ve upgraded the firmware and reconnected the VESC, it still says that the firmware is too old.

It doesn’t seem to store the new firmware. I’ve also tried to upgrade the bootloader but it doesn’t fix the problem.

This is what I use:

VESC Tool - Version 1.08

VESC HW - Version 4.12

VESC FW - Version 3.50 (I want to upgrade to version 3.54 like my other VESC).

Please help me! :disappointed_relieved:

Or, is it possible to download the correct VESC Tool that supports FW version 3.50? I can’t find it anywhere :confused:

You would have to download the older firmware and manually install it or just use the tool that you originally used with your other Vesc. I would just update both with the new tool.

Thanks for ur reply! :slight_smile:

I used the new tool for my old VESC. Same tool for this one but still it doesn’t want to upgrade…

Oh interesting… And they are both the same hardware?

Yup, HW 4.12

But the old one came with FW 2.18 and the new one with FW 3.50

I would double check the bootloader thing. I know you checked, but usually missing bootloader is what does not give you to update a new FW.


The thing is that it does actually write the new firmware, it just doesn’t seem to save it… It writes just fine but then when I reconnect it still says that it’s too old… :frowning:

Maybe just install acks firmware instead and see how that goes?

Oh, haven’t heard of that. Does it work with VESC Tool? :slight_smile:

I think that’s exactly what it looks like if no bootloader. Vesc tool will not give you a fault message. You can start the fw flashing and it finish successfully, but after reboot the fw is not updated.

I think with the new vesc tool you can upload the bootloader without need of an st v2 link. Just give it a try.

Yup, that’s what I did. I uploaded the bootloader with the latest VESC Tool!

You need the ackmaniac version of the vesc tool, but if your bootloader not give you to update that will also not work.

Ok, this is so wierd :confused:

Did you try loading any other older fw? Maybe 3.38 or something you have at home?

No I don’t have anything else than the one installed…

Oh, yes I’ve tried with an older version of VESC Tool

The same?

You need to use one ESC as a programmer to flash the other. Simply connect both SWDs together (GND IO and CLK only) GND to GND, IO to IO, CLK to CLK. Cables should be short, 6-8cm only!

Then you connect to the working ESC ( the one with the latest FW on) via VESC-Tool and open the SWD PROG tab. Now you flash the non working ESC with the 410,411,412 file.



That’s a cool way to do it. so for people that don’t have st link they just need to make a cable if they have a dual setup.

I would have thought that without the bootloader the esc won’t even connect to the PC though…