VESC HELP - After 10 mins no power


I build a mountainboard:

Setup: 6374 192KV SK3 motor VESC 6 or 12s Lipo setup 9" wheels 4.8:1 gear ratio

Tried 6s and 12s setups - no big diference in performance and distance. Tried FOC - works, but also lack of performance. I can forget about climbing 5-10% hills.

My VESC last setup screens:

I got basicly 8 km from half 12s 5000mah battery.

Problems: All power only for 5 minutes and then max speed about 10-15km/h. When I wait for 5 mins and I get power back for 3-5 mins and then 15km/h top speed. Totaly no hill climb power. My weight about 60kg (130 pounds).

Can somebody tell me where to dig for solving this problems? Maybe gear ratio? Or my VESC gots too hot? Current limit too low? Temperature limits too low?

Thank you!

@NerijusM it sounds like one of the VESC’s low-voltage thresholds is being surpassed. That would explain the temporarily reduced power. Are you sure your batteries are delivering the voltage consistent with your settings above? More info about your battery config would probably help the folks here on the forum that are likely to have a complete answer. Good luck!

Thanks. Battery made from series or parallel, depends on 6 or 12s. Screens are for 12s setup i ride today.

Sorry for bump, but I realy need some advice. Ordered 12T pulley, will try. For now changed startup boost to 0.15 and current limit to 50A. Better, but no so.

It’s either low voltage cut off, or the FETs on teh board are overheating.

It was FET overheating. Changed pulley to 12T, so now 1:6 gearing and board like new - flies!

Thank you. Good luck. Take care.