VESC. How can I download VESC older firmware 2.16 and where can I download it from?

My vesc is 4.12 hardware version, tried to install 4.12 firmware but it says " firmware on conected vesc is 2.16". Is there a way I can download older vesc firmware 2.16?

What is FOC?

Thank you in advance for the help. This is my first build and first time messing around with eboard stuff.

Welcome! It sounds like you already have firmware v2.16, so no need to download and install it again. I suspect you’re a little lost on all of the version numbers (and it can be a little confusing), so I’l give you a quick run down (I apologize in advance if this is old news for you). To start with, the firmware version numbers do not match the hardware version numbers. There’s some correlation, as in some firmwares only work on some hardwares and vice-versa. The other wrench that’s thrown into this is BLDC Tool (the computer application that you use to connect to your VESC to change its parameters). It has some limitations on the firmware versions it supports. The current release of BLDC tool only supports firmware v2.17 and v2.18 to my knowledge.

Now with all that, by “4.12 firmware” do you mean firmware v2.18 (the current release)?

FOC is Field Oriented Control. It’s a different way for the VESC to control the motor. It’s usually a bit quieter than BLDC mode. See here:

If you haven’t already, I’d recommend reading this:

The circuit board says vedder 4.12. But when I click on connect in bldc tool, it says my firmware is too old on vesc. when I try to update firmware from bldc folders (4.10, 4.11, 4.12) it keeps giving me a buffer reader timedout error and doesnt let me connect to the vesc. check out pics. Im going crazy, i even went on google and found old version of firmware including 2.16. I tried uploading the 2.16 firmware so that i can then uldate to the current 2.18 but i still get buffer read timeout error code. yes i did read the link you sent me already. SMH. Thank you.

Thanks for having read that. Many don’t :slight_smile: You already have v2.16 and if I’m understanding that correctly, I think the download you have (where it’s pointing to on your desktop) is still v2.16. The process you’re doing should update it without any problems to v2.18, as long as the file you’re pointing to is v2.18.