VESC Monitor Android App

newest firmware (3.101) and Bldc, but it also happens in FOC. Tried both. I can also send you a video if neccessary

Jesus. Now I see the problem. It happens when motor max is lower than motor min. Will work on it and provide a fix soon. Man that’s scary.


Found the issue in the software and fixed it. I will try to release a new version tomorrow which fixes that issue. Thx a lot to @gaetjen and @rok who didn’t gave up to convince me that the problem isn’t on their side.


Never! :grinning: You’re the man, thanks!


@rok and @gaetjen


Just released new Version 1.97

it improves the connection and has one very cool new feature. You are now able to connect to Ackmaniac-Tool or VESC-Tool via the app. To do so you need to press the question mark sign on top and then in the menu the entry “Start TCP Connection”

Then a popup window will appear that shows you the IP of your smartphone and the Port you need to connect to.

Then in the Ackmaniac-Tool go to connections, select the TCP tab and enter the id and port. Then press connect.

If it doesn’t work at all then please stop and restart the Wifi connection of your phone. Of course your Smartphone and PC need to be in the same network for this. If you are outside and have your Laptop then you can activate a Hotspot on your Phone and connect to the Hotspot with your Laptop. Hope it works for everybody.

Donations are always welcome and will be invested directly in :coffee: which i had a lot in the last days for the new firmware and app version.


That’s awesome, so I guess in order to be able to work wireless with both of the vesc we would need to bluetooth modules connected to the vescs. Is it correct? Anyhow I can connect via TCP. Thx

You can connect via CAN with the app and also with the ACKMANIAC-Tool or VESC-Tool.


Sorry I didn’t explain properly. I know I can change the motor battery setting through the app and via CAN be transfered to the slave VESC. My question was about firmware update. Is it possible to update the firmware om the VESC via TCP? Do O need 2 bluetooth modules km that case? Thx

That’s a cool feature! Quick question.

Anything that is limited on the Ack-tool when connecting to the app via TCP? For instance, would motor detection work? When reading real time data in the tool via app it looks like the ack-tool looses connection/read once every few seconds, so it doesn’t run very smooth. Is this just how it is when running though TCP ?

No firmware updates won’t work. Over Bluetooth it happens that packages get lost. And for a firmware update it needs to deliver like 20000 packets. So that won’t work. But motor detection, and read and write of settings works.

@Sebike I don’t understand what you want to say.

1 Like

Thats the dream @Ackmaniac! Wireless, wireless everything :heart_eyes:

Ok, so here is realtime data taken from the vesc when connected via USB and then via the app (TCP)



@Ackmaniac you are the man! Connecting wireless to the pc tool is the only thing I’ve been missing!

donation incoming :smiley:

Yes the connection isn’t as stable as with USB. Best is to place the phone and Laptop close to your WIFI Router and the board close to the Phone. Also be aware that the reliability of your Bluetooth connection can be very different in portrait (vertical) and Landscape (horizontal) position. And if you want a faster connection you could increase the baud rate of your Bluetooth module via AT commands. And Heart Beat (Heart sign) should best be deactivated because it occupies the connection a lot. Samples will also not work. Just simply see it as a possibility to read and modify your settings without taking the enclosure off.


I’ve been writing a couple of times about not getting KV reads in the terminal of the Ackmaniac-tool, so as the feature was implemented with the app I thought I’d try it, but unfortunately with the same disappointing results =

it just says measured kv: 0.00 rpm/v. ERPM reads are fine when checking for that, but not kv. I’ve tried this on both motors (running dual focboxes).

Any thoughts why?

Because the motors need to spin to detect the kv. So just speed them up, release the throttle and immediately enter the kv command while they still spin. the value you will see then needs to be devided by (number of magnets/2). So when you get 1330 then devide it by (14/2). 1330 / 7 = 190

If you have a 6374 190kv motor then don’t be surprised when you get a value in the 170kv range.

Yes, this is what I’m doing getting 0.00 rpm/v

full throttle, 50% throttle, release throttle with motor spinning… weird

I tested on different PC, but basically I can connect easy via TCP but I can not read the configurations present on the VESC both motor and app. Do you have any idea why?

Post a video when you try to connect and read the settings. That might help.