VESC Monitor Android App

Is it possible to control the speed of motor via bluetooth? Not just maximum speed, but actual speed.

Yessssss! It is showing realtime data again (Android 7) :grin: Thanks for the new version!

Hi, I got the 105mm Skullboard/DIY Airless Hubs and they got a tempsensor. I can read it out with the AC-Tool via PC and Android Phone like you explained, but like @Mathias said, it doesn’t get recorded. Is it possible to have a checkbox somewhere to enable and disable motor temp recording? Like you said, 99% of the motors don’t have tempsensors, but a NTC is like 50ct and you can place it everywhere, either glue it inside the motors by yourself or just place it onto battery, BMS, Antispark switch, connectors…whatever.

I’m using the VESC tool but this question is also relevant to the Ack app

How do i prevent others from connecting to my deck and changing settings? Is there any security that i can incorporate? Just imagining changing settings during a group ride

That all dependent on the BT module you use , not really the app itself if I’m remembering correctly

http://fab.cba.mit.edu/classes/863.15/doc/tutorials/programming/bluetooth.html

Hey, i am struggling somehow with similar problems. On my old phone (android 6…) i had no problems connecting to the BT module. The App version was 1.73 i guess. After updating to your actual version V1.115 it is connecting, but not reading any data. Same issue with my android 8.xx.

I second this request.

Answered already in the other thread. Please don’t ask the same question multiple times in different threads.

1 Like

I have developed HM-10 derivative using BGM111 Silabs’s BLE module. It was good working before 5 month ago as you can see below.

But now it does not work. After the app is updated. Perhaps the app does not seem to send CCCD when the PDU size exceeds 20 bytes when connecting to ble. Is this different from before upgrading?

Hello, im new to this tool, i followed every guide and instructions i fount, i managed to get both my foc box updated and set to run in sensored foc mode, managed to bind my alien tech remote the problem im having is getting the blue tooth to work, i did as instructed,UART baud is 9600 bps, the esc tool on my phone detects the hmsoft module and when i connect to it i do not see any data, if i throttle nothing happens in my phone app. any advice appreciated.

Rx on the vesc is connected to TX on the module? And you power it by the 5V pin?

I’m sure this has been answered before but I cannot find it for the life of me, so here goes: If I have dual focboxes connected via PPM, when I first connect the module to one of them do I have to disconnect the other one before I turn on and start setting it all up?

Hi. After I update my vesc 4 to latest 3.4 firmware after connection to Bluetooth module I no see data. What I can do with this? Uart is 9600. Previously works good

Do you use PPM + UART?

Sure. I try 3 vesc. Same situation. Before update work good - after no. :frowning:

Oh, i just forgot that i didn’t add the latest official firmware versions to the app. Think the last one that works is 3.38.

1 Like

Can you do this in future? Your app is fantastic!!! I think you have your own firmware? Where I can see difference from official and download it?

It’s available here

i am using vesc6 and the trampa bluetooth module. the program connects fine to the bluetooth, but i get no readings. Will this module work with your program? am i probably doing something wrong?(i did read the whole thread to double check) Thank you

I never tested it but i think the trampa bluetooth modules don’t work with my app.