VESC motor detection failure - R-SPEC

Your VESCS may have the current ramp bug in their firmware. I know this because mine did this. Check this post>>
If you’re not careful you can burn out your DRV chip while doing motor detections.

This wouldn’t affect the motor detection

Are you sure? The “spike” in current could be because the Vesc is ramping it up too fast because of the bug. This is the only explanation I have from my experiences.

This bug have been correct in the new 2.18 firmware. And like @Blasto said it shouldn’t affect the motor detection.

Please don’t recommend resetting the max voltage limit. This is bad practice and can lead to a a total loss of brakes. The max voltage limit is to protect the vesc components, leave it at 57v.

Ok, thanks for letting us know. Suppose we all need our brakes.

If you are running huge motors you may want to drop it down to 55v if you are running 12s. You can get some really quick spikes in voltage that could pop some components during throttle bursts and sudden braking. Sometimes the stm chip can’t react fast enough to protect the components so a little more buffer is good…sometimes.

I did all my Vesc setup including motor detection with a Lab power supply set at 12v with no problems at all. The 32a during motor detection seems way off. Maybe a short in the motor or bad solder joint on phase wires.

1 Like

How much amperage should an r-spec motor be drawing in a motor detection?

My power supply only delivers 5a max. So I’m guessing the motor detection should draw less than 5a at 12v

You set detection current. It should be at 3A by default

1 Like

You got it working with a power supply 12V 5A? I have read these days that many people have problems with detection when they use a low voltage ( <4S )

Chaka uses 12v. I just followed his lead and it worked perfectly on both of my dual Vescs and AP 190kv motors.

Where exactly is that setting on bldc tool?

Next to the button “start detection” is a value input called “Current”. I think 6A is standard.

This evening I tried the detection test with 8s I still had spikes of 32amps during the test. I then tried using the arrow keys. I had spikes of 20amps. Both of these tests were with the tested till test amp level at 6.0 amps. Here is a video of the test, I’m not sure what going on and I hope the sound helps to diagnose the problem.

The first 3 runs are from the detection test and the rest are from me pressing the arrow keys.

sounds normal to me. It always takes more energy to start up a motor from standstill. Having a burst for a small fraction of a second is normal.

The motor is still “spluttering” I’m working on the video The test keeps failing

Ah got it. Wasn’t aware of context. Is this sensorless, and have you tried swapping the phase wires around?

Its an R-spec motor and yeah and do you mean the wires going to the motor?