VESC not recognized by os

I have 2 VESCs hw v4.10. One connects to bldc tool, one does not. I get the blue light on the vesc, but nothing else. It is not recognized by the os. I have 3 different pcs and 6 usb cables.

Here is what I get: Connected to win 10, 8, 7, xp - not in device manager. No new device at all. Connected to Linux (ubuntu, centos) - dmesg results: no vesc, no unknown device.

Connected to working vesc via canbus - bldc tool: set CAN Fwd get message that cannot connect

Connected to 2 different stlink V2 - make upload: init failed.

All of these techniques work on the other vesc(except canbus of course) , the one that works.

I have also had stlink wiring checked by someone at vedder’s site and it works on the other vesc.

With respect to ground; is there 3.3V present on the reset and 3.3V pin?

Yes. 3.3V on both

To bad, that would have been an easy fix.

There are now 4 main options:

  1. the crystal is incorrect / bad soldered.
  2. crystal capacitors are bad / wrong value
  3. Wrong or no firmware (do you have programmer?)

Or just the general soldering errors around USB / micro controller.

Yes. I have 2 different stlink v2. I can’t get the make upload to work on the bad vesc. I can get each stlink to connect to os properly. But when I try make upload, I get:

Error: open failed in procedure ‘transport’ ** OpenOCD init Failed ** shutdown command invoked.

My apologies, I don’t know where my mind was neglecting you tried to program them with a debugger :(.

Well, in this case (3.3 present and reset @ 3.3): The STM needs only power to be programmed -> check for shorts and opens in the program wires and if STM is placed with correct orientation ( happend to me, don’t laugh). Can you maybe post a few pictures?

Wires are 6" long.

other programmer

when i connect either, I get blue light on vesc

You need to connect the data pin, also known as SWIM. On the VESC it is the 6th pin, unlabeled.

still fails. same error on make upload

Check all the pins on the stm32 chip. Might have a small bridge somewhere.

ok, checked all the connections. seemed ok. switched to other programmer. same error

checked continuity on the back of each board. all jumpers are working

I think something might be wrong with the mcu. You might need to replace it. Check for bridges.

If your wires are really 6" long I am supprised that you managed to program the other ones( did you program the others?). I have bad experience with long wires ( unless you lowered the swd clock speed ).

All other stuff sounds and looks like it should work. Where are you situated? Your name sounds France?

6" is 6 inches not much longer than the width of my hand

And I am in denver colorado, usa

I have carefully looked over the entire board under magnificaion. All the solder joints look perfect to me. Not sure what to do now.

At this point, you might as well try re-flowing the whole pcb with flux and a heat gun.