Vesc not responding to remote

just upgraded to vesc from a rc car esc i connected my vesc to my motor and 6s battery and my controller that i binded to the reciever that is connected to the vesc. The setup it unresponsive and the pulsewidth in BLDC tool isnt moving when i move my throttle. I used this same throttle and bound it to my rc esc setup and it works so what could be wrong? Links to my parts: VESC: Motor: Battery (2 of these in series to get 6s):

Reboot your vesc ,??

tried that.

here are my BLDC tool settings

Do you have any picture of your setup?

Have you try changing the channel ?

Yes i tried using the remote while charging it and also using it after it is charged

Are your servo cable plug in the ch1 or ch2 ?

Channel 1 and the red led is on when i turn my controller on so they r connected

Hummm… but in your picture your plug in the channel 3 or the binding channel… You should be plug in the ch1 see the image below.

1 Like

Just tried changing it to channel 1 and the same problem persists

The red led shows it is connected but the vesc doesnt respond to it

Sorry for the late answer… I’m not really sure of what went wrong with tour remote, but maybe retry the process following this video

@Ryanliu did you ever come to a resolution on this? I think I’m having a similar/the same issue and can’t seem to get it working. I know the post is super old, but I didn’t see a resolution anywhere. I’ve tried both ppm and UART connections to no avail.

I’m currently having the same issue, did you ever find a solution?

Up. I have the same issue. It was working before, but lately i can’t map the remote, vesc doesn’t respond and doesn’t read the movement of two of my rc remotes (shows - 100% ppm)

Anyone find a solution yet???

Did you find the solution to this? I have 3 VESCs that don’t respond to any input from UART or PPM.