Vesc not spinning up motor on test

Hello, i have a problem with my first skateboard build, I have a Vesc from (bought on the forum so it’s known good) and every time i try to do the motor detection test it twitches the motor and then gives me a failed detection test,

i’m running 2x 5000mh zippy 3 cells in series and am trying to drive an SK3 285kw turnigy motor, the only thing i’ve done is replaced the bullet connectors on the vesc otherwise all is standard.

my min charge cutoff i have had set at 0 and still the same, i’ve tried the amps up to 12 in the test to no avail also, I have tried another usb cable- same result,

is there anyway to test the motor to see if the problem lies there?

anyone have any ideas this is killing me! thanks for your time.

Okay do you want to die??? The wire on the antispark is exposed and you cannot touch the metal or bad things will happen to you

First of all, isolate everything…

Then send us more pictures of your BLDC and circuits, how is everything connected together…

Go to terminal and type in “faults” and see if you get anything. And how are you placing the motor?

Its just a loop key, you wont get shocked or short anything If you touch it

Its still dangerous, theres current going through that thing.

I wont say its dangerous before you expose both the negative and the positive…

O.K you’re right unisolated anti spark not really good!- fixed!

no faults on the terminal (thanks for that never knew about it)

the motor is only on a mount at the moment as i would like to know it works before putting i on the board

here is my connections,

so it’s positive from the vesc through the anti spark going to an xt60 going to the battery pack with another leg going to a charging point the negative is going direct to the xt60 for thr battery pack and then doubling back to the charge point.

should i make screen shots from the vesc tool? if so which ones, many thanks for your speedy replies and help

Make sure the motor can spin freely and there is no resistance, and make sure the circlip isnt being held down by the mount. Take screenshots of the first page when you open vesc tool, and the motor settings (motor detection page)

Edit: Im assuming youre using an sk3?

yes it’s an SK3, the motor is able to spin freely and the circlip is not obstructed, i’m using the wizard for setup should i do it manually?

Hmmm im not experienced with this vesc tool, most people use the other bldc tool

Can you post your Bldc settings on the left?

should i download the other tool and use that?

some more settings

Thank you all ever so much for the help, after 10 hours of pulling my hair out i found the problem, when i soldered the new bullets to the vesc i managed to splash a bit of solder onto one of the mosfets causing a bridge, totally my bad, but thanks to another members post i new what i was looking at as soon as i eventually saw it, so thanks again and happy riding!, i will post some pics as soon as i get this board finished.

1 Like

So did your motor detection pass after fixing the solder bridge?

sorry for the late reply, yes it did, today i am finishing my case and themn it will be the final build up (hopefully)!