VESC Nunchuk RF

I desoldered the NRF module, but my problem still persists, i need to “activate” the nunchuk. So it is not related to NRF module any way. Next thing that i can think of is that if i have some wrong component on board. Something that is related to stm chip booting. I’m using the right BOM, V5.

And i quickly tried that source you posted, it is different than what i found, since it behaves like you said, red and green is swapped. But i need to look more into it.

Maybe your “activation” thought was misleading, when searching for the error. When you connect to a usb-port you also switch to a different power source … namely your computer! I would really take a closer look to U3 and U4. Is one of them getting hot, you did not swap them accidentally, are the “looking” all right?

I just checked them again, and they are the right way. And also smd markings match what they should be. They are not heating. And they look alright. Power sources are the right way. When i plug USB, the blue LED lights. And the markings are all clear where the battery goes and where USB.

What else i could call it than activation. software power switch triggered by data? :slight_smile:

When i look at the schematic, it looks that only thing that could be causing this problem would be the USB-bridge. Counterfeight chip with some pins swapped or something… that forces the nunchuk to be in some specific mode on boot… But that doesn’t explain why the original code doesn’t work and that ws2812 edition works. But i can test that option by desoldering the USB-bridge off.

EDIT: Yeah! The booting problem(aka. activating) is solved! I desoldered the CP2102 from the other nunchuk that i thought was broken. I applied power, and i needed to pair it only once, and whenever i connect the battery(actually lab power supply), it is automatically paired! So apparently now it works normal way. Except i can’t connect it to computer obviously…

Only two questions remain now… Will the original firmware work now, and were the problem counterfeit CP2102, or just bad soldering. The soldering appeared to be ok, but i need to wire the chip with thin enameled wire to the pcb so it is 100% every needed pad soldered.

Original firmware works too, just red and green switched. You used a heat gun to solder the grounding underneath the CP2102? If not, you can not connect as you already have experienced. Why do you have to use a wire??? Give me a photo!

I soldered it the same way i solder all of the same kind of packages. pre-tinning, flux and heat gun. Including the ground plane. Wires this time just to make sure all the pads are connected. To confirm if the chip(s) are fake or just bad soldering.

I also had some problems regarding the proper connection of the CP2102, since there are no visible pins, just some sort of corners underneath. After using the heat gun I re-soldered every “pin” with a very fine tin solder and a very, very fine solder tip. After that I had no more problems, connection was good and so far reliable.

Okay, i tested with wires. Exactly the same behavior as before. So the chips are either counterfeit of partially broken. Here’s some pictures.

IC removed, device working perfectly:

IC soldered with wires: (ground looks bad on picture. it’s not)

EDIT: So far it is working good. Now i have another problem, longboard battery died, i need to wait for new batteries to arrive. The current cells are already bad, used for testing purposes, to be replaced with better ones. But that’s another story.

But about the CP2102. What i have read on internet, the problem may be related to RTS and DTR pins. What i’ll try, is to control those two pins with switches and see what happens. EDIT: Okay. When i disconnect the RTS signal, it starts working. So i need just one switch for RTS.

EDIT: The original firmware is still not working…

1 Like

Are you compiling the newest version from Benjamins github? I think he has changed some pieces in the software (using STM32s ID) in his last commit. I would try the software before that last commit. Maybe that will work for you.

1 Like

Yea, newest from github. Now i had the time to compare those sources. The difference (most likely) why they are not working straight away is that some values on rf.c are different and need to be changed on BLDC Tool. Newest — other version: NRF_RETR_DELAY_1000US — NRF_RETR_DELAY_250US NRF_SPEED_2M — NRF_SPEED_250K

I don’t have now time to test those settings, but some day next week i will.

@Quezacotl Do a full revert back to the pre-December 2016 version. He changed a lot more than the speed and delay settings. Vedder also added some capability to have the nunchuck auto-pair with a VESC (even changed the communication packet/protocol on it) but the VESC code does not have any similar features that I am aware of (so I suspect this is a feature we’ll only see in the VESC6). This change also means that the resistors are not longer used to make the address, so the 198.199.(resisotr binary values) we’ve been using don’t work. He completely deleted that code.

Oh, true. Seems that it relies on STM32 chip’s unique ID. Apparently it will be in next VESC firmware, not only in VESC6 i hope.

With VESC-Tool that will be sorted. My VESC 4 with external NRF module does the automatic pairing just fine.


I figured as much. But us laymen don’t have that VESC firmware or code base yet, and we don’t have a release date for that, so we have stick to reverting to a previous version.

True, but it won’t be long until its released.


Damn i like that dead bug style soldering! Respect

1 Like

perhaps its too late but alcohol works wonders at breaking down hot glue…

1 Like

Now i soldered a presumably genuine CP2102 chip. I ordered it from Mouser when i got some other parts aswell. The “activation” problem i was talking earlier still exists. So the problem is not in the USB chip. I have made even a third remote, which has the same problem. I have confirmed that all the components have right values, and they are on right places. Still the only “solution” i have is to put a switch between BOOT0-signal.

I am still quite baffled by your issue. All the one’s I’ve made (5 or so now) wake up perfectly when you press (and hold for a second) the Z and C buttons…

Yea, very strange problem. I need to inspect carefully every single part including the PCB next time i bother to dig into this again.

But today i noticed that while the BOOT0 signal is cut, the databridge works still through BLDC-tool. I didn’t even test that feature when i saw that programming won’t work. I just assumed that databridge wouldn’t work either. So actually the BOOT0-signal is only for programming.

Do you Still make them? I’d like to buy a populated board if you do!