VESC PPM settings

I just tested it’s real life performance again (but faster this time…) and it seems to still accelerate up to top speed insanely quickly. Before half throttle, I’m already going my max speed… Haha, I was kinda hoping it would be as simple as a performance change once I stood on it, but it doesn’t look like that’s the answer!

PPM settings can be a little counter intuitive at first. If you are still having trouble dialling it in send me an email and we can do a skype session and get it sorted out.

4 Likes

I don’t recall changing any settings like that, is there a reason you are changing the settings?

I just plugged the gt-2b RX in and it was good to go.

Sounds like you need to increase your maximum pulsewidth, You will probably need to decrease your minimum pulsewidth to keep dead stick at 50%

A simple way to find your min and max values is by monitoring the pulsewidth values in the lower right hand side of the screen while fully depressing the throttle and brake. Those values will give you a good starting point. You will still need to adjust them slightly to find the sweet spot.

check this out:

Thanks for the help everyone!

I’ll work on it tomorrow, and try to figure it out. Now that I think about it, widening the minimum and maximum endpoints should do the trick, but I’ll have to wait and see when I actually test it.

If I can’t seem to get it tomorrow, I might take you up on that offer @chaka

Thanks again!

didn’t get a chance to check it today unfortunately, but Thanksgiving break is in two days. I’ll be able to work on it then without school and tennis practice taking up my whole day…

woah I just realized you play tennis. you compete?

u ever got your ppm setting right? im having the same issue and on top of that as soon as i get to my destination if i turn my remote of with out turning the board off before the motor star spinning at full speed i almos had to ran behing my board hahahaha, good thing i had one foot on it still, any ideas???

What remote do you have? Sounds like you need to set your throttle mid on your receiver.

i have a mastercho mod (gt2b) do u mean on the transmitter?

The receiver. Try re-binding the remote doing the whole rebind process.

ill try it tonight when i get home, before switching to ppm last nigh i was riding the non ppm mode i guess idk whats called, and also the throttle was already max at 1/3,
i thougth the binding procces is just to sync remote with speed controller dou think that by rebinding ill actually change anything??

Rebind also sets the throttle mid value on the receiver, at least on my remote.

u have a gt2b?

Winning remote. Pretty similar receivers though. They work with each other.

aight ill try it when i get home tonight, thank you man i hope thats it what bothers me the most is the board taking out when i turn transmitter off, the throttle im kind of use to already since i been riding like that since i put it together a month ago, and ya know first build u just want to wrap it up asap and go skate

If you adjust the PWM on the remote you have to rebind to set neutral on the receiver. I had similar result when I adjusted without rebinding. Turning off remote = throttle forward.

i hope u are online tonight just in case i need help!