VESC problem: Motor won't spin, no fault on the BLDC tool


I’m using my electric skateboard for a while now, made one for a friend too. After he was doing some work on his board, on the first test, the motor just didn’t want to spin anymore.The problem is, that I have no idea why…

So far I did this:

Changed cables and motor. Tried with a 3s setup, different battery On the BLDC tool, it says no faults. Voltage going in is correct, min. Voltage is set correct. Changed the receiver and remote, on the bldc tool the throttle bar works (not dissabled) Motor detection doesn’t work. (bad results received) Voltmeter on the VESC, on the battery side shows the actual voltage. But on the motor side always 0 Volt (tired all the combinations, since there are 3 cables). When pressing the throttle up, the realtime date shows movements, but only <1amp.

One thing, I am not sure about, is that my friend put some “Conserveringspry VA23” on the BLDC tool. Might that be the problem? Although, it worked until he took everything apart. Another thing, is that he put the VESC next to a really strong magnet over night… Can this cause problems? But what could be defective on the VESC?

Thank you very much in advance