is online! Public VESC-Tool download

A new Version is online! Some of the features requested are already implemented now. Throttle curves for brakes and acceleration is split now, fixed RT data time scale and some other minor things… VESC-Tool will tell you that there is an update. Latest Version now: V0.81



What about the FOC function on HW4.7 with the new code?

Well, focbox foc R is 0 Error!


and it also loaded 4.10 instead of 4.12

4.10 and 4.12 is the same hardware, just some slight routing changes

1 Like

Okay I debugged it. It seems like first detection stuck the motor for some reason, so it won’t be able to detect from the first place! U first need to set up the app, PPM for me. write default motor setting than run the motor a bit. Than come back to motor detection! It works in both BLDC and FOC now, Phew~

Update, FOC is detected but not working, for bizar reason it shorts the motor and making tiny sound. does not respond to ppm… well BLDC for a while I guess :cry:

Update2: A side from initial setup bug, I noticed there is bug with ppm setting. for FOC it short the motor when connected to Receiver, regardless the remote on or off. It’s like a failsafe mod. I couldn’t figure out what the cause. But it clearly works well on BLDC. Note: I plugged out receiver to prevent interference when setting FOC.

Notice that I use mac ver,(not official) FOCBOX, sk3 260kv 10s5a, with unloaded motor.

I tested with both 2.18 and Akman’s 2.54, both works fine. And to go back to old fmw, u upload from vesc tool and use old tool.

not too sure if the tool or fmw problem tho

Works. I ran a 4.7 for more than a year in FOC.


So, as i’m having trouble now with the new vesc tool getting the sensor values on BLDC do I just ante up and try FOC?? My vescs are the last production enertion before VESC X…

Anybody tested updating a Maytech DRV cooker with this new VESC- Tool ?? And if so tested with FOC ?

Yes, bootloader and FW upload works… tested FOC with my maytech’s :joy: everytime hitting the brake results in DRV fault and cut off on both V4.12, forget maytech and buy quality HW, with proper V4.12 FOC works like a charm.

1 Like

Sensors work a lot better in FOC. Frank

1 Like

Ok, thanks for the info. But you can at least use custom throttle curves and so on in BLDC mode? I have a “beater” board with a maytech vesc and the “boost” is really pronounced here, so if this is gone with the tool that would be great. Agreed with quality HW in these things.

The new FW works in BLDC mode with maytech , FOC not :wink:

1 Like

It’s always good to have FOCtimized HW.



Any confirmation to the boost being gone even in hybrid mode?

Again I thought soeed boost was a hardeare issue not software…

Frank, thanks for your reply

I configured PPM input signal using wizard. My remote did work before, I’ve been using this board for a week now with no problems.

Voltage is set for a 10s battery.

Here you can see some settings too


When you set it to “Current with no reverse with brake” Did you remember to hit the "Write app config. " ??

Did you make sure to choose the app in “App Settings > General > App to use” AND choose a control type under “App settings > PPM > Control Type”?

Also whenever your motor doesn’t move, avoid pull the throttle all the way like that, easy to way to blow your VESC and/or motor.

1 Like

Yea, I think this was it. I wasn’t changing this setting in both places. Now it works. Thanks guys !

If anyone else has this problem, this is how you set up your remote in the new vesc tool.


Off topic : is that your Z? That’s one of my favorite cars period. Liked your post just for that haha

1 Like