Vesc randomly shutting off

Hello, I know there are plenty of threads about this topic already but I couldn’t find anything that could be triggering my problem. Basically the vesc just feels like it will turn off for a couple seconds randomly. Sometimes it happens when im accelerating and sometimes it happens when I try to brake, not accelerating hard or braking hard. Has happened 2-3 times but today was the last straw when I was trying to brake to keep myself from going into an extremely busy street at about 15mph, there was a car behind me and I was forced to jump off and almost get hit by the car behind me. I’m running the diy vesc, 6s2p epower pack with a single tacon bigfoot 245kv motor. I don’t think it’s a motor short because I haven’t ever seen any sort of spark from the motor, any help is appreciated :slight_smile:

Can you post screenshots of your vesc settings? That would be a good starting place for folk to help you.

I run the same setup and no issues. Post your vesc settings

What remote are you using?

If you’re using the winning remote, you’ll neet to setup the failsafe. Otherwise when your remote has signal issue’s (standard for the winning remote :fearful:) and it disconnected, it’ll fully break instead of going into “neutral”. You can check for this issue when you’re watching the green bar in your VESC settings, disconnect your remote and if the percentage goes to 0, that’s your issue.

Otherwise, a bad connection between the motorwires and the vesc (like a loose connector) could cause the same issue.

Next time it happens, plug your VESC into your PC (don’t restart your VESC), start the BLDC tool, click the “Terminal” tab. Then type in faults and click “Send”.

If it’s a VESC fault, you’ll see it shown here.

I’ve got the GT2B. I think I may have just fixed it by leaving a bit of the reciever antenna out of the enclosure. I havent tested it yet, but I do know I programmed the vesc to coast if I loose connection so that definitely could have been the problem, will test later today

Same thing was happening to me, just was a loose tab on the :battery: and the sparks in that tab are not your friend, almost killed my pack. I hope you find out soon the problem, good luck!!

Oh man, I hope that’s not the problem. If so maybe Dexter will be able to do a repair for me, I’ve loved everything about this battery so far :confounded: